summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2021-08-30 15:00:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-02 12:05:56 +0100
commit05706a487c2e57fb26935276a2ec650405900243 (patch)
treec29bfb5dcdaddcba564eec7565dc1a3b92eb9b9a /meta/recipes-graphics/wayland
parentabe45c8c0a6da56a278796654d0520250dfd2a97 (diff)
downloadopenembedded-core-05706a487c2e57fb26935276a2ec650405900243.tar.gz
weston: Add rdp PACKAGECONFIG
Weston has RDP backend support. This can be used e.g. for screen mirroring. Add PACKAGECONFIG so it can be enabled by the user. By default, this is not enabled, to retain the old behavior of the recipe. Below is an example testcase of using the RDP backend for screen mirroring, i.e. two devices display the same content across ethernet link, input on either is passed across the link. - Add the following to weston.ini: [core] modules=screen-share.so screen-share=true [screen-share] command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize --rdp-tls-cert=/path/to/board.crt --rdp-tls-key=/path/to/board.key --no-config - Generate keys on the board (the board.key and board.crt above): $ winpr-makecert -rdp -path /path/to/ - Restart weston on the board. To start screen sharing, press Ctrl-Alt-S on the keyboard (see weston compositor/screen-share.c). - Connect to the weston using freerdp, e.g.: $ xfreerdp /v:192.168.1.300 Signed-off-by: Marek Vasut <marex@denx.de> Cc: Joshua Watt <JPEWhacker@gmail.com> Cc: Khem Raj <raj.khem@gmail.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/weston_9.0.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston_9.0.0.bb b/meta/recipes-graphics/wayland/weston_9.0.0.bb
index cbc2e6a1cd..1f1d62ea7c 100644
--- a/meta/recipes-graphics/wayland/weston_9.0.0.bb
+++ b/meta/recipes-graphics/wayland/weston_9.0.0.bb
@@ -33,7 +33,7 @@ LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '',
WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
-EXTRA_OEMESON += "-Dbackend-default=auto -Dbackend-rdp=false -Dpipewire=false"
+EXTRA_OEMESON += "-Dbackend-default=auto -Dpipewire=false"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl clients', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
@@ -59,6 +59,8 @@ PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libx
PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false"
# Weston on framebuffer
PACKAGECONFIG[fbdev] = "-Dbackend-fbdev=true,-Dbackend-fbdev=false,udev mtdev"
+# Weston on RDP
+PACKAGECONFIG[rdp] = "-Dbackend-rdp=true,-Dbackend-rdp=false,freerdp"
# weston-launch
PACKAGECONFIG[launch] = "-Dweston-launch=true,-Dweston-launch=false,drm"
# VA-API desktop recorder