aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2012-06-20 10:57:50 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-25 16:32:14 +0100
commite7b3040f0a0f5356949e6a51d9d9d1c8dcf1f3c9 (patch)
treeae2b6d2c4cbf833fcaaa96c9e820e87518265959 /meta/recipes-graphics
parentd99cc2b70bbda9a0cbc09a4430b871c287113041 (diff)
downloadopenembedded-core-e7b3040f0a0f5356949e6a51d9d9d1c8dcf1f3c9.tar.gz
xev: updated to 1.2.0
tested on sato Signed-off-by: Valentin Popa <valentin.popa@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-app/xev/diet-x11.patch38
-rw-r--r--meta/recipes-graphics/xorg-app/xev_1.0.3.bb10
-rw-r--r--meta/recipes-graphics/xorg-app/xev_1.2.0.bb10
3 files changed, 29 insertions, 29 deletions
diff --git a/meta/recipes-graphics/xorg-app/xev/diet-x11.patch b/meta/recipes-graphics/xorg-app/xev/diet-x11.patch
index 139838c357..6130959f86 100644
--- a/meta/recipes-graphics/xorg-app/xev/diet-x11.patch
+++ b/meta/recipes-graphics/xorg-app/xev/diet-x11.patch
@@ -4,11 +4,11 @@ Upstream-Status: Inappropriate [disable feature]
xev.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
-Index: xev-1.0.2/xev.c
+Index: xev-1.2.0/xev.c
===================================================================
---- xev-1.0.2.orig/xev.c 2006-06-02 00:25:44.000000000 +0100
-+++ xev-1.0.2/xev.c 2007-05-10 15:22:07.000000000 +0100
-@@ -109,7 +109,7 @@ do_KeyPress (XEvent *eventp)
+--- xev-1.2.0.orig/xev.c
++++ xev-1.2.0/xev.c
+@@ -116,7 +116,7 @@ do_KeyPress (XEvent *eventp)
nbytes = XLookupString (e, str, 256, &ks, NULL);
/* not supposed to call XmbLookupString on a key release event */
@@ -17,7 +17,7 @@ Index: xev-1.0.2/xev.c
do {
nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
buf[nmbbytes] = '\0';
-@@ -119,7 +119,7 @@ do_KeyPress (XEvent *eventp)
+@@ -126,7 +126,7 @@ do_KeyPress (XEvent *eventp)
buf = realloc (buf, bsize);
}
} while (status == XBufferOverflow);
@@ -26,7 +26,7 @@ Index: xev-1.0.2/xev.c
if (ks == NoSymbol)
ksname = "NoSymbol";
-@@ -149,7 +149,7 @@ do_KeyPress (XEvent *eventp)
+@@ -156,7 +156,7 @@ do_KeyPress (XEvent *eventp)
}
/* not supposed to call XmbLookupString on a key release event */
@@ -35,16 +35,16 @@ Index: xev-1.0.2/xev.c
printf (" XmbLookupString gives %d bytes: ", nmbbytes);
if (nmbbytes > 0) {
dump (buf, nmbbytes);
-@@ -157,7 +157,7 @@ do_KeyPress (XEvent *eventp)
+@@ -164,7 +164,7 @@ do_KeyPress (XEvent *eventp)
} else {
printf ("\n");
}
- }
+ } */
- printf (" XFilterEvent returns: %s\n",
+ printf (" XFilterEvent returns: %s\n",
XFilterEvent (eventp, e->window) ? "True" : "False");
-@@ -804,7 +804,7 @@ main (int argc, char **argv)
+@@ -1015,7 +1015,7 @@ main (int argc, char **argv)
fprintf (stderr, "%s: XSetLocaleModifiers failed\n", ProgramName);
}
@@ -53,30 +53,30 @@ Index: xev-1.0.2/xev.c
if (xim == NULL) {
fprintf (stderr, "%s: XOpenIM failed\n", ProgramName);
}
-@@ -831,7 +831,7 @@ main (int argc, char **argv)
+@@ -1042,7 +1042,7 @@ main (int argc, char **argv)
}
XFree (xim_styles);
}
-- }
-+ }*/
+- }
++ }*/
screen = DefaultScreen (dpy);
-@@ -891,7 +891,7 @@ main (int argc, char **argv)
+@@ -1109,7 +1109,7 @@ main (int argc, char **argv)
printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
}
- if (xim && xim_style) {
+ /*if (xim && xim_style) {
- xic = XCreateIC (xim,
- XNInputStyle, xim_style,
- XNClientWindow, w,
-@@ -901,7 +901,7 @@ main (int argc, char **argv)
+ xic = XCreateIC (xim,
+ XNInputStyle, xim_style,
+ XNClientWindow, w,
+@@ -1119,7 +1119,7 @@ main (int argc, char **argv)
if (xic == NULL) {
fprintf (stderr, "XCreateIC failed\n");
}
- }
+ }*/
- for (done = 0; !done; ) {
- XEvent event;
+ have_rr = XRRQueryExtension (dpy, &rr_event_base, &rr_error_base);
+ if (have_rr) {
diff --git a/meta/recipes-graphics/xorg-app/xev_1.0.3.bb b/meta/recipes-graphics/xorg-app/xev_1.0.3.bb
deleted file mode 100644
index 21ba62e246..0000000000
--- a/meta/recipes-graphics/xorg-app/xev_1.0.3.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require xorg-app-common.inc
-LIC_FILES_CHKSUM = "file://xev.c;startline=0;endline=35;md5=db2e69260ca64f1d332efa6ab4b7e2b5"
-DESCRIPTION = "X Event Viewer"
-LICENSE = "MIT"
-PE = "1"
-
-SRC_URI += "file://diet-x11.patch"
-
-SRC_URI[md5sum] = "a9532c3d1683c99bb5df1895cb3a60b1"
-SRC_URI[sha256sum] = "d4ac7ae154ee9733be27a5f55586abb9362c768f5fb8a4fc7fd2645100a9313a"
diff --git a/meta/recipes-graphics/xorg-app/xev_1.2.0.bb b/meta/recipes-graphics/xorg-app/xev_1.2.0.bb
new file mode 100644
index 0000000000..b3404092ed
--- /dev/null
+++ b/meta/recipes-graphics/xorg-app/xev_1.2.0.bb
@@ -0,0 +1,10 @@
+require xorg-app-common.inc
+LIC_FILES_CHKSUM = "file://xev.c;startline=0;endline=35;md5=2f39a0038b59269c1e62efae64cfd056"
+DESCRIPTION = "X Event Viewer"
+LICENSE = "MIT"
+PE = "1"
+
+SRC_URI += "file://diet-x11.patch"
+
+SRC_URI[md5sum] = "2727c72f3eba0c23f8f6b2e618d195a2"
+SRC_URI[sha256sum] = "3786a77dab17741d508d5d117a0ff33bb6eabf93e0935388b5f920bfcf2fb38f"