aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-03-25 14:03:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-25 14:26:53 +0000
commita167176c3e41e4eb2a1931df566367e3da2b3b86 (patch)
treeabee895b991e82b7f03d8d410599db1299642097 /meta/recipes-graphics
parent0d3a5282bd84edd4100fc8855f5c4ab7d6016803 (diff)
downloadopenembedded-core-a167176c3e41e4eb2a1931df566367e3da2b3b86.tar.gz
libxcb: fix repeated configures
If configure is re-ran on an existing build tree the string substitutions we need are done twice, resulting in invalid paths. Anchor the expressions so they only match a pristine configure.ac. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xcb/libxcb.inc8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-graphics/xcb/libxcb.inc b/meta/recipes-graphics/xcb/libxcb.inc
index 5f4df69b28..124fe3d426 100644
--- a/meta/recipes-graphics/xcb/libxcb.inc
+++ b/meta/recipes-graphics/xcb/libxcb.inc
@@ -51,12 +51,12 @@ FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
inherit autotools pkgconfig pythonnative
-# XCBPROTO_XCBINCLUDEDIR is setup based on `pkg-config --variable=xcbincludedir xcb-proto`
+# XCBPROTO_XCBINCLUDEDIR is set based on `pkg-config --variable=xcbincludedir xcb-proto`
# but the xcbincludedir variable doesn't point into the staging area, so it needs some
-# tweeking here:
+# tweaking here:
do_configure_prepend () {
- sed -i "s|XCBPROTO_XCBINCLUDEDIR=|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/|" \
+ sed -i "s|XCBPROTO_XCBINCLUDEDIR=\`|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/\`|" \
${S}/configure.ac
- sed -i "s|XCBPROTO_XCBPYTHONDIR=|XCBPROTO_XCBPYTHONDIR=${STAGING_DIR_HOST}/|" \
+ sed -i "s|XCBPROTO_XCBPYTHONDIR=\`|XCBPROTO_XCBPYTHONDIR=${STAGING_DIR_HOST}/\`|" \
${S}/configure.ac
}