aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-16 14:59:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-16 16:48:24 +0100
commitf45a03b510479f6c27b24a0fd8d0c661674495e1 (patch)
treeccd0ff98d1fd76e615d2c7777dce45f35c012d43 /meta/recipes-graphics
parent1a70a3225947aa45f3e1f377d50a5865aac64d2b (diff)
downloadopenembedded-core-f45a03b510479f6c27b24a0fd8d0c661674495e1.tar.gz
xserver-xorg: fix segfaults for ARM SoCs
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg-1.14.0/0001-dixstruct.h-fix-segfaults-char-is-unsigned-for-ARM-a.patch39
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg_1.14.0.bb3
2 files changed, 41 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.14.0/0001-dixstruct.h-fix-segfaults-char-is-unsigned-for-ARM-a.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.14.0/0001-dixstruct.h-fix-segfaults-char-is-unsigned-for-ARM-a.patch
new file mode 100644
index 0000000000..16f0489c85
--- /dev/null
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.14.0/0001-dixstruct.h-fix-segfaults-char-is-unsigned-for-ARM-a.patch
@@ -0,0 +1,39 @@
+From a095f5005be66c1b9747187e91e5332b0d8b106b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Tue, 16 Apr 2013 13:47:22 +0200
+Subject: [xserver 1.14/master] dixstruct.h: fix segfaults - char is unsigned
+ for ARM and PowerPC architectures
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+see ARM related bug reports [1-3]
+
+Upstream-Status: Submitted [4]
+
+[1] https://github.com/archlinuxarm/PKGBUILDs/issues/446I
+[2] http://www.raspberrypi.org/phpBB3/viewtopic.php?t=38568&p=321673
+[3] http://lists.linuxtogo.org/pipermail/openembedded-core/2013-April/037805.html
+[4] http://lists.x.org/archives/xorg-devel/2013-April/036010.html
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ include/dixstruct.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/include/dixstruct.h b/include/dixstruct.h
+index 6784819..aef822c 100644
+--- a/include/dixstruct.h
++++ b/include/dixstruct.h
+@@ -96,7 +96,7 @@ typedef struct _Client {
+ unsigned int clientGone:1;
+ unsigned int closeDownMode:2;
+ unsigned int clientState:2;
+- char smart_priority;
++ signed char smart_priority;
+ short noClientException; /* this client died or needs to be killed */
+ int priority;
+ ReplySwapPtr pSwapReplyFunc;
+--
+1.7.6.5
+
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.14.0.bb b/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.14.0.bb
index 83b80494ea..8c573bdf30 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.14.0.bb
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.14.0.bb
@@ -6,12 +6,13 @@ SRC_URI += "file://crosscompile.patch \
file://mips64-compiler.patch \
file://aarch64.patch \
file://fix_compilation_when_not_using_xinerama.patch \
+ file://0001-dixstruct.h-fix-segfaults-char-is-unsigned-for-ARM-a.patch \
"
SRC_URI[md5sum] = "86110278b784e279381b7f6f2295c508"
SRC_URI[sha256sum] = "1f5107573252c26439fdd165481765a2c0964e02a2e9fab36e02414d08f30630"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
# These extensions are now integrated into the server, so declare the migration
# path for in-place upgrades.