summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-23 17:17:36 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-24 17:45:28 +0000
commit9ac7415464b7817aa5cc0c2167ff61f4344660dd (patch)
tree516d37fc8a0b762f1af593ae477c131a8509e577 /meta/recipes-graphics
parentd85d529e967a8f092fb2085d1d3c24370d751309 (diff)
downloadopenembedded-core-9ac7415464b7817aa5cc0c2167ff61f4344660dd.tar.gz
fontcache: fix postinst for nativesdk case
Both installing the binary into the correct place, and passing that place to postinst_intercept were missing. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
index beeae7fb10..8fa739de24 100644
--- a/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
@@ -42,6 +42,12 @@ do_install_append_class-target() {
ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache
}
+do_install_append_class-nativesdk() {
+ # duplicate fc-cache for postinstall script
+ mkdir -p ${D}${libexecdir}
+ ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache
+}
+
PACKAGES =+ "fontconfig-utils"
FILES_${PN} =+ "${datadir}/xml/*"
FILES_fontconfig-utils = "${bindir}/* ${libexecdir}/*"