aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux-firmware/linux-firmware_git.bb
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-09-01 15:45:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-20 15:10:36 +0100
commit907e6596275850cc31b143a4c3094029b0cd078e (patch)
tree3f5ad715b1d238d0498fd9b8f749de4304f63762 /meta/recipes-kernel/linux-firmware/linux-firmware_git.bb
parent3d4bf5b0ea581e3e9b388328b086d03f9174fd61 (diff)
downloadopenembedded-core-907e6596275850cc31b143a4c3094029b0cd078e.tar.gz
linux-firmware: package carl9170 separately
Package the carl9170 binary firmware separately because it is needed by various usb dongles and installing whole linux-firmware is overkill. carl9170 is an atheros-based firmware, the succesor of ar9170 which is deprecated and its driver (ar9170) was removed from the kernel tree. carl9170 comes both as a binary blob and also with free sources; the sources are deleted in linux-firmware.bb to avoid depeding on bash/etc. Also we should keep ar9170 as is because OOT drivers might still use it. The license for carl9170 is GPLv2 (sources are beside the bin in the linux-firmware git repo). Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux-firmware/linux-firmware_git.bb')
-rw-r--r--meta/recipes-kernel/linux-firmware/linux-firmware_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux-firmware/linux-firmware_git.bb b/meta/recipes-kernel/linux-firmware/linux-firmware_git.bb
index 53e7374345..2421da0943 100644
--- a/meta/recipes-kernel/linux-firmware/linux-firmware_git.bb
+++ b/meta/recipes-kernel/linux-firmware/linux-firmware_git.bb
@@ -226,7 +226,7 @@ PACKAGES =+ "${PN}-ralink-license ${PN}-ralink \
${PN}-vt6656-license ${PN}-vt6656 \
${PN}-rtl-license ${PN}-rtl8192cu ${PN}-rtl8192ce ${PN}-rtl8192su \
${PN}-broadcom-license ${PN}-bcm4329 ${PN}-bcm4330 ${PN}-bcm4334 ${PN}-bcm43340 ${PN}-bcm4339 ${PN}-bcm4354 \
- ${PN}-atheros-license ${PN}-ar9170 ${PN}-ath6k ${PN}-ath9k \
+ ${PN}-atheros-license ${PN}-ar9170 ${PN}-carl9170 ${PN}-ath6k ${PN}-ath9k \
${PN}-ar3k-license ${PN}-ar3k ${PN}-ath10k-license ${PN}-ath10k \
\
${PN}-iwlwifi-license ${PN}-iwlwifi \
@@ -256,6 +256,9 @@ FILES_${PN}-atheros-license = "/lib/firmware/LICENCE.atheros_firmware"
FILES_${PN}-ar9170 = " \
/lib/firmware/ar9170*.fw \
"
+FILES_${PN}-carl9170 = " \
+ /lib/firmware/carl9170*.fw \
+"
FILES_${PN}-ath6k = " \
/lib/firmware/ath6k \
"
@@ -267,6 +270,7 @@ FILES_${PN}-ath9k = " \
"
RDEPENDS_${PN}-ar9170 += "${PN}-atheros-license"
+RDEPENDS_${PN}-carl9170 += "${PN}-atheros-license"
RDEPENDS_${PN}-ath6k += "${PN}-atheros-license"
RDEPENDS_${PN}-ath9k += "${PN}-atheros-license"