aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-11-30 17:58:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 10:49:14 +0000
commit73ac48377491561151658617d8cc45936242eb0c (patch)
treec0509c4fc260019be097f769b05fdf593b5b97a7 /meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch
parentc2094366ea0771c520d52f0b73b8df1bd74e7941 (diff)
downloadopenembedded-core-73ac48377491561151658617d8cc45936242eb0c.tar.gz
trace-cmd: Update to 1.2 (includes kernelshark)
Update the trace-cmd and kernelshark recipes to version 1.2. Rename the recipes to the more descriptive trace-cmd_1.2.bb and kernelshark_1.2.bb respectively. Update addldflags.patch for 1.2 and current Upstream-Status (Accepted). Add make-docs-optional.patch to avoid building the new doc target which requires asciidocs. We should add asciidocs and properly package the docs, but for now it's more important to get the sources current. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch')
-rw-r--r--meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch28
1 files changed, 18 insertions, 10 deletions
diff --git a/meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch b/meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch
index 8e8f578e61..14730db905 100644
--- a/meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch
+++ b/meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch
@@ -1,29 +1,37 @@
-Upstream-Status: Pending
+trace-cmd: Cross-compile fixes for LDFLAGS and include path
Add ability for the Makefile to respect LDFLAGS.
-
Also remove hardcoded /usr/local/include include path.
-RP 7/5/2011
+Upstream-Status: Accepted [Post 1.2: 5f576e9af7ad706774d9764a9ae3989376797c0e]
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+
+---
+ Makefile | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
Index: git/Makefile
===================================================================
---- git.orig/Makefile 2011-07-05 11:58:11.699910550 +0100
-+++ git/Makefile 2011-07-05 23:30:12.319920617 +0100
-@@ -189,10 +189,11 @@
+--- git.orig/Makefile
++++ git/Makefile
+@@ -202,12 +202,13 @@ export Q VERBOSE
TRACECMD_VERSION = $(TC_VERSION).$(TC_PATCHLEVEL).$(TC_EXTRAVERSION)
KERNELSHARK_VERSION = $(KS_VERSION).$(KS_PATCHLEVEL).$(KS_EXTRAVERSION)
-INCLUDES = -I. -I/usr/local/include $(CONFIG_INCLUDES)
+INCLUDES = -I. $(CONFIG_INCLUDES)
+ include features.mk
+
# Set compile option CFLAGS if not set elsewhere
CFLAGS ?= -g -Wall
+LDFLAGS ?=
- # Append required CFLAGS
- override CFLAGS += $(CONFIG_FLAGS) $(INCLUDES) $(PLUGIN_DIR_SQ)
-@@ -225,7 +226,7 @@
+ ifndef NO_PTRACE
+ ifneq ($(call try-cc,$(SOURCE_PTRACE),),y)
+@@ -251,7 +252,7 @@ do_fpic_compile = \
do_app_build = \
($(print_app_build) \
@@ -32,7 +40,7 @@ Index: git/Makefile
do_compile_shared_library = \
($(print_shared_lib_compile) \
-@@ -237,7 +238,7 @@
+@@ -263,7 +264,7 @@ do_compile_plugin_obj = \
do_plugin_build = \
($(print_plugin_build) \