aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 13:22:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 13:23:47 +0000
commit053ca014e7eb8c9dd05cef42fe23f463f3eb15dd (patch)
treee339982aa152d6214d6ef8968f50885a5a402234 /meta/recipes-kernel
parentdeb99cefe8be7fa63972edadf69f92d361b9a7c5 (diff)
downloadopenembedded-core-053ca014e7eb8c9dd05cef42fe23f463f3eb15dd.tar.gz
perf: Fix parsing error
Due to the use of ${@...} the code will try and expand this when performing the initial parsing. If the sysroot doesn't exist with an existing kernel, this will fail at parsing time. Sinec we're already in python, just remove the ${@....} wrapping and then we execute at do_package time which is what we want. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 182dd25d6e..210c4cbf65 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -105,7 +105,7 @@ do_configure_prepend () {
}
python do_package_prepend() {
- bb.data.setVar('PKGV', '${@get_kernelversion('${S}').split("-")[0]}', d)
+ bb.data.setVar('PKGV', get_kernelversion('${S}').split("-")[0], d)
}
PACKAGE_ARCH = "${MACHINE_ARCH}"