aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-03-26 07:46:32 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-26 17:48:06 +0000
commit779cb6e51fab87e00784bd97ec4771e69a79cf82 (patch)
treed8b94191fce861e86ed7e19f3e7be609a34216bb /meta/recipes-kernel
parent827106a57ca88760a19f9309d859b500c5c4fe97 (diff)
downloadopenembedded-core-779cb6e51fab87e00784bd97ec4771e69a79cf82.tar.gz
linux-yocto/3.8: allow kernel feature _appends to be overriden
It was pointed out that the current way the KERNEL_FEATURES variable is appended in the base linux-yocto recipe doesn't allow the appended features to be prevented in a layer without using python code and a recipe finalize hook. To allow easier overriding of 'extra' or 'optional' features that are defined in the linux-yocto recipe, we create a KERNEL_EXTRA_FEATURES variable. This variable can be set in a layer to define extra features or cleared to prevent the recipe's extra features from being appended to the core functionality. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
index b395e45488..f29675aab2 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -23,8 +23,7 @@ KMETA = "meta"
COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
# Functionality flags
-KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append_qemux86=" ${KERNEL_EXTRA_FEATURES} cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" ${KERNEL_EXTRA_FEATURES} cfg/sound.scc"
KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"