aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-04-12 02:16:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-12 17:00:13 +0100
commitddce9f375c626ef2c86f48612b3d7a24e3111b0b (patch)
tree89625c97f136b5a505b147fe26a4eec96d27cc31 /meta/recipes-kernel
parent60fabb6ea0474b19ad57873b402a608a92c5a5d4 (diff)
downloadopenembedded-core-ddce9f375c626ef2c86f48612b3d7a24e3111b0b.tar.gz
kern-tools: fix non-local patch/config location
A regression was introduced when implementing the ability to restrict configuration values via include directives. Only patch and config files that were local to a feature directory could be found. While this doesn't impact most users of the tools, it is an issue that needs to be fixed. Additionally, the regex that detected flags passed to includes was not specific enough, and unfortunately named feature files would match. This resulted in features like standard-nocfg.scc inhibiting all configuration items, even base configs. This change also bumps the linux-yocto 3.4 and 3.8 PR values to ensure that kernels will be rebuilt once this change is active. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb2
7 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 9dcd896bcf..acef4b5889 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=d8d1d729a70c
DEPENDS = "git-native guilt-native"
-SRCREV = "e3f59062bc594239856549e165c9e373cbbac1d6"
+SRCREV = "7a3170d96e142ce85a958f5b22e45f68f785f58d"
PR = "r12"
PV = "0.1+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
index 42339a1a1f..88c05e264b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
@@ -12,7 +12,7 @@ SRCREV_machine ?= "7302a8f84da657ff72ca5a27b9212c9d3bee2fbf"
SRCREV_machine_qemuppc ?= "494b16c51c6f6dc272eb820eaa57028ca8ee9da2"
SRCREV_meta ?= "80b4b5110dca5184b57e85f1e775fb006a2e85ad"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb
index 3bf937f91b..04642a4df0 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb
@@ -12,7 +12,7 @@ SRCREV_machine ?= "0f7d294a9d07713059af345188f9cd4f549b4e77"
SRCREV_machine_qemuppc ?= "82cdb00523b3f86219706d9f12dc80ff8d1c747a"
SRCREV_meta ?= "27b63fdbd25ad1a37bacc05f49a205c150d21779"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
index 4b6b4a015e..54202b099a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
@@ -15,7 +15,7 @@ KMETA = "meta"
SRCREV_machine ?= "c994390cfa28339cbc1ec3b56eeec83a5fa75bb7"
SRCREV_meta ?= "80b4b5110dca5184b57e85f1e775fb006a2e85ad"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
index 5a3331710a..1fe4139e8f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
@@ -15,7 +15,7 @@ KMETA = "meta"
SRCREV_machine ?= "11998bd1f44b21cd0b8c0ca11cbd36865f14bfdc"
SRCREV_meta ?= "27b63fdbd25ad1a37bacc05f49a205c150d21779"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 604aa48f90..b81b9ace7b 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -15,7 +15,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone
LINUX_VERSION ?= "3.4.36"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
index c0906e52ab..91cc52debf 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -15,7 +15,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone
LINUX_VERSION ?= "3.8.4"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"