aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-04-05 12:00:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-05 22:47:44 +0100
commitf2a2256f08287baac9cf1f9fd58b5b8244c09610 (patch)
treecee4dea9979aed8b8769f68600bb5860465f6655 /meta/recipes-kernel
parentb9e4f67c6ec5762a65e3e5611ea95b9c96247241 (diff)
downloadopenembedded-core-f2a2256f08287baac9cf1f9fd58b5b8244c09610.tar.gz
linux-yocto-tiny: Add 3.8.4 recipe
Bring linux-yocto-tiny up to the latest linux-yocto 3.8.4 version. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
new file mode 100644
index 0000000000..07b620cdbc
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
@@ -0,0 +1,26 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+# We need lzma (as CONFIG_KERNEL_LZMA=y)
+DEPENDS += "xz-native"
+
+KBRANCH_DEFAULT = "standard/tiny/base"
+KBRANCH = "${KBRANCH_DEFAULT}"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+LINUX_VERSION ?= "3.8.4"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "42ddf06111efe45f3c36012d5a04a1eeb9781f42"
+SRCREV_meta ?= "f86199dd4c142fae61517a993b3f7162bb6d4f94"
+
+PR = "${INC_PR}.0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""