aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-31 14:07:08 +0300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-10 16:15:17 +0100
commit1f3b3c75701b791cb32aba76f0a4448f5549fae3 (patch)
tree05a7ca3a6fd1e13501d226951edfe6d8d35d16cf /meta/recipes-multimedia
parentedf5a7fd6da804588fcc4f2687a7b05ecfda3beb (diff)
downloadopenembedded-core-1f3b3c75701b791cb32aba76f0a4448f5549fae3.tar.gz
alsa-tools: Fix configure race
aclocal is being called here directly, not called by autotools.bbclass wrapper. aclocal files are installed in sysroot, and are removed while build is still running. This translates to a possible race condition during the build. Fixes [YOCTO #4358]. (From OE-Core master rev: dea66ade1184cef6aeb242d87867759ca44a8895) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
index 81ad55acd3..24af545054 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
@@ -20,14 +20,20 @@ SRC_URI[sha256sum] = "553338693707fe6ddfc430b9edc4cd2677390e200c9e38de82ede3394e
inherit autotools
-EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"
+EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'"
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
PACKAGECONFIG[gtk+] = ",,gtk+,"
+do_configure () {
+ autotools_do_configure
+ autotools_copy_aclocal
+}
+
do_compile_prepend () {
#Automake dir is not correctly detected in cross compilation case
export AUTOMAKE_DIR=${STAGING_DATADIR_NATIVE}/$(ls ${STAGING_DATADIR_NATIVE} | grep automake)
+ export ACLOCAL="aclocal --system-acdir=${ACLOCALDIR}/"
}
FILES_${PN} += "${datadir}/ld10k1"