aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-06-24 11:26:28 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-16 10:39:45 +0100
commit4b2a41e8c28e4f05f1623d1d36eb4de26e1c7fa4 (patch)
tree97680a623c64a513466d5d28bb26e4b7469853b0 /meta/recipes-multimedia
parent9a9bfdcf4c0776e57dd85aec81f591a3f8307ff7 (diff)
downloadopenembedded-core-4b2a41e8c28e4f05f1623d1d36eb4de26e1c7fa4.tar.gz
gst-plugins-bad: element selection rationalisation
Using --with-plugins means you only get the elements you enable, so we were dropping vast numbers of useful plugins such as the MPEG muxers. Instead, follow gst-plugins-base by using PACKAGECONFIG to enable/disable plugins with optional dependencies. (From OE-Core master rev: 7722fd48995d5d430d58b94ecf69a6ad9f1c741b) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb18
1 files changed, 12 insertions, 6 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
index 68451f2708..7e80ce4e3a 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
@@ -6,18 +6,24 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c"
-DEPENDS += "gst-plugins-base curl"
+DEPENDS += "gst-plugins-base"
PR = "r4"
inherit gettext gsettings
-EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio --disable-directfb \
- --with-plugins=wavpack,mpegvideoparse --disable-vdpau --disable-apexsink \
- --disable-orc --disable-neon"
+EXTRA_OECONF += "--disable-experimental \
+ --disable-sdl --disable-cdaudio --disable-directfb \
+ --disable-vdpau --disable-apexsink"
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'librsvg', '', d)}"
-PACKAGECONFIG[librsvg] = "--enable-rsvg,--disable-rsvg,librsvg,"
+PACKAGECONFIG ??= "bzip curl \
+ ${@base_contains('DISTRO_FEATURES', 'x11', 'rsvg', '', d)}"
+
+PACKAGECONFIG[bzip] = "--enable-bz2,--disable-bz2,bzip2"
+PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
+PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg,"
+PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
+PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon"
ARM_INSTRUCTION_SET = "arm"