aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-03 15:54:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-04 10:08:03 +0000
commitfe81bd4f600877e63433184cfc2e22c33bb77db6 (patch)
treeba2d7dc4f88dbb48fa25cf234ca2a13ea09617a2 /meta/recipes-multimedia
parent6ed278ab93e9c3bb291dd37837c27e120954afc7 (diff)
downloadopenembedded-core-fe81bd4f600877e63433184cfc2e22c33bb77db6.tar.gz
recipes: Fix ALLOW_EMPTY with no package specified
There are various usages of ALLOW_EMPTY with no packages specified. This is not recommended syntax, nor is it likely to be supported in the future. This patch improves the references in OE-Core, either removing them if they're pointless (e.g. when PACKAGES="") or specifying which package it applies to. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb6
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-package.inc2
2 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb b/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
index 37c70c2190..210da3745e 100644
--- a/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
@@ -14,7 +14,11 @@ PACKAGES = "\
gst-meta-debug \
gst-meta-video"
-ALLOW_EMPTY = "1"
+ALLOW_EMPTY_gst-meta-base = "1"
+ALLOW_EMPTY_gst-meta-x11-base = "1"
+ALLOW_EMPTY_gst-meta-audio = "1"
+ALLOW_EMPTY_gst-meta-debug = "1"
+ALLOW_EMPTY_gst-meta-video = "1"
RDEPENDS_gst-meta-base = "\
${@base_contains('DISTRO_FEATURES', 'x11', 'gst-meta-x11-base', '', d)} \
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc b/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc
index f26aca5c85..3e9ef92fdd 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc
@@ -24,8 +24,6 @@ python populate_packages_prepend () {
d.setVar('DESCRIPTION_' + metapkg, pn + ' meta package')
}
-ALLOW_EMPTY = "1"
-
PACKAGES += "${PN}-apps ${PN}-meta ${PN}-glib"
FILES_${PN}-apps = "${bindir}"