aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-02-29 13:51:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 17:52:25 +0100
commit0c32b6e9585a39b14002a5da230222d2fe01ddff (patch)
tree6c51ce24ce822224ac3ab8f7fe6e1468a6a787af /meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
parentab2d5e397d30999929108c9d929767205fee9db4 (diff)
downloadopenembedded-core-0c32b6e9585a39b14002a5da230222d2fe01ddff.tar.gz
matchbox-session-sato: Update session startup
* Use Adwaita Gtk+ theme * sato-gtk-engine is no longer needed with Adwaita * GTK_CSD tricks are no longer needed since the panel does not draw on top windows * Add meta-theme index file: it used to be provided by gtk-sato-engine and is used by matchbox-config-gtk only (to be able to show a single selection for Gtk+, icon and Matchbox themes). This is a more logical place for it. * Set matchbox-theme gconf key (just to be explicit, this is the default already) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb')
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
index 76de18ae93..fb4750bafd 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be6
SECTION = "x11"
DEPENDS = "gconf-native"
-RDEPENDS_${PN} = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf"
+RDEPENDS_${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf"
PR = "r30"
# This package is architecture specific because the session script is modified
@@ -19,9 +19,12 @@ inherit distro_features_check
# The matchbox-theme-sato requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI = "file://session"
+SRC_URI = "file://session \
+ file://index.theme"
S = "${WORKDIR}"
+FILES_${PN} += "${datadir}/themes/Sato/index.theme"
+
do_install() {
# This is the set of machine features that the script has markers for
FEATURES="phone"
@@ -34,6 +37,7 @@ do_install() {
fi
done
+ install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
install -d ${D}/${sysconfdir}/matchbox
sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
chmod +x ${D}/${sysconfdir}/matchbox/session
@@ -44,7 +48,8 @@ pkg_postinst_${PN} () {
#type, name, value
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
}
- set_value string theme Sato
+ set_value string theme Adwaita
+ set_value string matchbox_theme Sato
set_value string icon_theme Sato
set_value bool touchscreen true
set_value string font_name "Sans 9"