summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-17 13:24:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-20 18:50:05 +0000
commit086c7ef9f90bc4946b53a1373cca539701501384 (patch)
tree30752ad3d9abc99161807f941a73cf33f50ec59a /meta/recipes-sato
parent5be97052ecfd5cc510651dddeb1291183240d1f3 (diff)
downloadopenembedded-core-086c7ef9f90bc4946b53a1373cca539701501384.tar.gz
webkitgtk: Add packageconfig to chose between size and speed
This packageconfig when selected will use -Os -DNDEBUG instead of -O2 -DNDEBUG, which should generate smaller binaries and libs but perhaps at the expense of some runtime performance, defaults are kept as it is size reduction when enabled --rwxr-xr-x root root 23503680 ./usr/lib/libjavascriptcoregtk-4.0.so.18.17.13 +-rwxr-xr-x root root 17536152 ./usr/lib/libjavascriptcoregtk-4.0.so.18.17.13 --rwxr-xr-x root root 53314616 ./usr/lib/libwebkit2gtk-4.0.so.37.49.9 +-rwxr-xr-x root root 40195672 ./usr/lib/libwebkit2gtk-4.0.so.37.49.9 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.30.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb
index 36d33f550d..ff4c496e2a 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb
@@ -59,6 +59,7 @@ PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
+PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
# webkitgtk is full of /usr/bin/env python, particular for generating docs
do_configure[postfuncs] += "setup_python_link"
@@ -70,7 +71,6 @@ setup_python_link() {
EXTRA_OECMAKE = " \
-DPORT=GTK \
- -DCMAKE_BUILD_TYPE=Release \
${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
-DENABLE_MINIBROWSER=ON \