summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-11-06 03:42:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-08 14:03:16 +0000
commit82ac2a91ea6adc33f2f10634fe0a3f1ad4d12e66 (patch)
tree571fc7eaf83267c0119abdc57d1a9b08f3527fba /meta/recipes-sato
parentdaddb89daf8c1048375cd2102b9819f8f1c2e41c (diff)
downloadopenembedded-core-82ac2a91ea6adc33f2f10634fe0a3f1ad4d12e66.tar.gz
webkitgtk: fix opengl PACKAGECONFIG
* ENABLE(OPENGL) was renamed to ENABLE(GRAPHICS_CONTEXT_GL) in r254064: https://github.com/WebKit/webkit/commit/92f9916b4a0d799c3f7be10b69aa53f40a149a2d and https://github.com/WebKit/webkit/commit/b3cb3ba4fa713e23ae27b2a79c14c6735d40d671 but AUH doesn't notice that and builds without opengl in DISTRO_FEATURES are now failing with: | CMake Error at Source/cmake/OptionsGTK.cmake:323 (message): | Either OpenGL or OpenGLES2 is needed for ENABLE_GRAPHICS_CONTEXT_GL. | Call Stack (most recent call first): | Source/cmake/WebKitCommon.cmake:58 (include) | CMakeLists.txt:173 (include) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.30.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.30.2.bb b/meta/recipes-sato/webkit/webkitgtk_2.30.2.bb
index 1acba6be1d..56cd1eb9d4 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.30.2.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.30.2.bb
@@ -48,7 +48,7 @@ PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geocl
PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
-PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"
+PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"