summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr
diff options
context:
space:
mode:
authorTimo Mueller <timo.mueller@bmw-carit.de>2015-02-03 13:21:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-07 13:30:56 +0000
commit4595e4832418afc651300c88ad2b835f0aedd8bc (patch)
treeb5cbd41222296f1747d2a141ad307904d15e1d5d /meta/recipes-support/apr
parenta8b85f7878726503dbfa2e9ea86bd6fd961bf03b (diff)
downloadopenembedded-core-4595e4832418afc651300c88ad2b835f0aedd8bc.tar.gz
apr-util: Allow use in SDK
This adds 'nativesdk' in the BBCLASSEXTEND. Building apr-util for the SDK requires that some paths in the rules.mk file are fixed to point to the actual enviroment. These include pointing the apr configuration variables to the actual apr builddir and correcting the name of the libtool. Signed-off-by: Timo Mueller <timo.mueller@bmw-carit.de> Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/apr')
-rw-r--r--meta/recipes-support/apr/apr-util_1.5.4.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.4.bb b/meta/recipes-support/apr/apr-util_1.5.4.bb
index ac01b63ecd..6a14d14d41 100644
--- a/meta/recipes-support/apr/apr-util_1.5.4.bb
+++ b/meta/recipes-support/apr/apr-util_1.5.4.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://apr.apache.org/"
SECTION = "libs"
DEPENDS = "apr expat gdbm"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
@@ -49,6 +49,17 @@ do_configure_append_class-native() {
sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${B}/build/rules.mk
}
+do_configure_prepend_class-nativesdk() {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+}
+
+do_configure_append_class-nativesdk() {
+ sed -i "s#\(apr_builddir\)=.*#\1=${STAGING_DATADIR}/build-1#" ${S}/build/rules.mk
+ sed -i "s#\(apr_builders\)=.*#\1=${STAGING_DATADIR}/build-1#" ${S}/build/rules.mk
+ sed -i "s#\(top_builddir\)=.*#\1=${STAGING_DATADIR}/build-1#" ${S}/build/rules.mk
+ sed -i "s#\(LIBTOOL=\$(apr_builddir)\).*#\1/libtool#" ${S}/build/rules.mk
+}
+
FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so"
FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/apr_dbm_gdbm.so* ${libdir}/apr-util-1/apr_dbm_gdbm.la"
FILES_${PN}-dbg += "${libdir}/apr-util-1/.debug/*"