aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/beecrypt
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2013-12-27 15:44:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-10 15:11:06 +0000
commitf344699eb15933cc7c92b0ed6894ef0869568659 (patch)
treec18c4985509810d76eb2b5307c61501354ef8821 /meta/recipes-support/beecrypt
parent6482a43211a3a4858030ae3c59f5726c0ccba261 (diff)
downloadopenembedded-core-f344699eb15933cc7c92b0ed6894ef0869568659.tar.gz
beecrypt: add ptest support
Install beecrypt test suite and run it as ptest. Make all ptest pass. Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Diffstat (limited to 'meta/recipes-support/beecrypt')
-rw-r--r--meta/recipes-support/beecrypt/beecrypt/beecrypt-enable-ptest-support.patch37
-rw-r--r--meta/recipes-support/beecrypt/beecrypt/run-ptest5
-rw-r--r--meta/recipes-support/beecrypt/beecrypt_4.2.1.bb12
3 files changed, 52 insertions, 2 deletions
diff --git a/meta/recipes-support/beecrypt/beecrypt/beecrypt-enable-ptest-support.patch b/meta/recipes-support/beecrypt/beecrypt/beecrypt-enable-ptest-support.patch
new file mode 100644
index 0000000000..3e5513fce9
--- /dev/null
+++ b/meta/recipes-support/beecrypt/beecrypt/beecrypt-enable-ptest-support.patch
@@ -0,0 +1,37 @@
+beecrypt: enable ptest support
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Add install-ptest rules.
+
+Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
+---
+ Makefile.am | 3 +++
+ tests/Makefile.am | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index b7e7869..5076f59 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,3 +73,6 @@ DISTCLEANFILES = mpopt.s blowfishopt.s sha1opt.s
+
+ bench:
+ (cd tests && $(MAKE) $(AM_MAKEFLAGS) bench)
++
++install-ptest:
++ (cd tests && $(MAKE) $(AM_MAKEFLAGS) check_PROGRAMS)
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 1604e5e..d8db8d8 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -101,3 +101,6 @@ bench: benchme benchrsa benchhf benchbc
+ ./benchbc AES 128
+ ./benchbc Blowfish 128
+ ./benchbc Blowfish 128
++
++check_PROGRAMS:
++ $(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS)
+--
+1.8.1.2
+
diff --git a/meta/recipes-support/beecrypt/beecrypt/run-ptest b/meta/recipes-support/beecrypt/beecrypt/run-ptest
new file mode 100644
index 0000000000..5bc7460be9
--- /dev/null
+++ b/meta/recipes-support/beecrypt/beecrypt/run-ptest
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd tests
+for i in `ls`; do ./$i; if [ $? == 0 ]; then echo "PASS: $i"; \
+ else echo "FAIL: $i"; fi; done
diff --git a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
index 46834d2149..209b92e653 100644
--- a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
+++ b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
@@ -8,7 +8,10 @@ HOMEPAGE = "http://sourceforge.net/projects/beecrypt"
SRC_URI = "${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
file://disable-icu-check.patch \
file://fix-security.patch \
- file://fix-for-gcc-4.7.patch"
+ file://fix-for-gcc-4.7.patch \
+ file://run-ptest \
+ file://beecrypt-enable-ptest-support.patch \
+ "
SRC_URI[md5sum] = "8441c014170823f2dff97e33df55af1e"
SRC_URI[sha256sum] = "286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d"
@@ -20,7 +23,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9894370afd5dfe7d02b8d14319e729a1 \
PR = "r3"
-inherit autotools multilib_header
+inherit autotools multilib_header ptest
acpaths=""
do_install_append() {
@@ -37,3 +40,8 @@ FILES_${PN}-dev += "${libdir}/${BPN}/*.so ${libdir}/${BPN}/*.la"
FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a"
BBCLASSEXTEND = "native nativesdk"
+
+do_install_ptest () {
+ mkdir ${D}${PTEST_PATH}/tests
+ cp -r ${B}/tests/.libs/test* ${D}${PTEST_PATH}/tests
+}