aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/createrepo
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-13 18:58:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-13 20:09:22 +0100
commitb5028cc84ad7c40c51cadbdf7fdc892cde4462cb (patch)
tree11d12e29826bc7a62f46978572d75e8e4120b2bc /meta/recipes-support/createrepo
parent44c2fb7ea0228dd749129d334c76a1bd2983e585 (diff)
downloadopenembedded-core-b5028cc84ad7c40c51cadbdf7fdc892cde4462cb.tar.gz
createrepo: add wrapper script to fix paths
Fixes sstate relocation due to the path to /etc/rpm being baked into the libraries - this manifested in the form of the following assertion at runtime: python: dbconfig.c:493: db3New: Assertion `dbOpts != ((void *)0) && *dbOpts != '\0'' failed. Fixes [YOCTO #2753]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/createrepo')
-rw-r--r--meta/recipes-support/createrepo/createrepo_0.4.11.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-support/createrepo/createrepo_0.4.11.bb b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
index 42c7214bb2..344cc77770 100644
--- a/meta/recipes-support/createrepo/createrepo_0.4.11.bb
+++ b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
RDEPENDS_${PN}_virtclass-native += "libxml2-native rpm-native"
-PR = "r6"
+PR = "r7"
SRC_URI= "http://createrepo.baseurl.org/download/${BP}.tar.gz \
file://fix-native-install.patch \
@@ -36,4 +36,9 @@ do_install_append_virtclass-native () {
${D}${bindir}/rpm-createsolvedb.py ; do
create_wrapper $i ${STAGING_BINDIR_NATIVE}/python-native/python
done
+
+ create_wrapper ${D}/${bindir}/createrepo \
+ RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+ RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+ RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
}