aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-09-30 04:08:59 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-01 07:40:37 +0100
commit3e4978a534afc7fd4b82a044da8d9774cf09a4f0 (patch)
treef1d79a7e3875bb95dfe611e5735e4505c3803576 /meta/recipes-support/curl
parent7e13fc603aa86219bf15e355ca9ea9275308cca5 (diff)
downloadopenembedded-core-3e4978a534afc7fd4b82a044da8d9774cf09a4f0.tar.gz
curl: cleanup buildpaths from curl-config
curl-config will be installed to target, cleanup buildpaths in it: * remove ${STAGING_DIR_HOST} from CC, CFLAGS ... Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl')
-rw-r--r--meta/recipes-support/curl/curl_7.44.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.44.0.bb b/meta/recipes-support/curl/curl_7.44.0.bb
index b293303da3..f6d350e86a 100644
--- a/meta/recipes-support/curl/curl_7.44.0.bb
+++ b/meta/recipes-support/curl/curl_7.44.0.bb
@@ -45,6 +45,11 @@ do_install_append() {
oe_multilib_header curl/curlbuild.h
}
+do_install_append_class-target() {
+ # cleanup buildpaths from curl-config
+ sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
+}
+
PACKAGES =+ "lib${BPN}"
FILES_lib${BPN} = "${libdir}/lib*.so.*"