aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-04 21:14:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:17:22 +0100
commit11267f8a1ccf65142988b095351a84b0fa0fcbcf (patch)
tree1f1ae25b44971fe4fa202ca3f93ca670a932c2d2 /meta/recipes-support/db
parent662637decc23888c9b0da93807257943bab14583 (diff)
downloadopenembedded-core-11267f8a1ccf65142988b095351a84b0fa0fcbcf.tar.gz
python: Fix to support the python module _bsddb built with db 5.3
_bsddb module in python 2.7 could be built only with db version between 4.1 and 4.7. A patch was added to avoid build warning about this for [YOCTO #1937] but not actually fixed it. This patch enable _bsddb module be built with db 5.3, and remove --disable-statistics from the DB5_CONFIG to fix segmentation fault when using _bsddb module in python. [YOCTO #2749] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db')
-rw-r--r--meta/recipes-support/db/db_5.3.15.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/db/db_5.3.15.bb b/meta/recipes-support/db/db_5.3.15.bb
index 0fc396ee97..063954af46 100644
--- a/meta/recipes-support/db/db_5.3.15.bb
+++ b/meta/recipes-support/db/db_5.3.15.bb
@@ -14,7 +14,7 @@ HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
LICENSE = "Sleepycat"
VIRTUAL_NAME ?= "virtual/db"
RCONFLICTS_${PN} = "db3"
-PR = "r7"
+PR = "r8"
SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.."
@@ -56,7 +56,7 @@ FILES_SOLIBSDEV = "${libdir}/libdb.so"
#configuration - set in local.conf to override
# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
-DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-statistics --disable-verify --disable-compat185 --disable-sql"
+DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
EXTRA_OECONF = "${DB5_CONFIG}"