summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/diffoscope
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-24 12:41:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-24 12:42:45 +0000
commit93ad1ab49be03dd082a98f80464cfee9d98a3a33 (patch)
treecd73c6ee1b3be61f21231f541bec3abb4318ccce /meta/recipes-support/diffoscope
parent044eda9c70ddda195b1c0ce1d228904392431582 (diff)
downloadopenembedded-core-93ad1ab49be03dd082a98f80464cfee9d98a3a33.tar.gz
diffoscope: Ensure rpm is configured correctly
diffoscope was failing as rpm wasn't configured correctly. Fix this. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/diffoscope')
-rw-r--r--meta/recipes-support/diffoscope/diffoscope_167.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-support/diffoscope/diffoscope_167.bb b/meta/recipes-support/diffoscope/diffoscope_167.bb
index af9682e0a8..74cd809071 100644
--- a/meta/recipes-support/diffoscope/diffoscope_167.bb
+++ b/meta/recipes-support/diffoscope/diffoscope_167.bb
@@ -15,7 +15,10 @@ RDEPENDS_${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magi
COMPATIBLE_HOST_libc-musl = 'null'
do_install_append_class-native() {
- create_wrapper ${D}${bindir}/diffoscope MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
+ create_wrapper ${D}${bindir}/diffoscope \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
+ RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
}
BBCLASSEXTEND = "native"