aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gmp
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-05-02 13:37:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 11:17:36 +0100
commit902a528867292172bfb060a31767f7b5e39f40c1 (patch)
tree50341dca3cf639177cad00bfe773903884c85fd4 /meta/recipes-support/gmp
parente1f818e0b534404897767897c167b2f5cd13ad07 (diff)
downloadopenembedded-core-902a528867292172bfb060a31767f7b5e39f40c1.tar.gz
gmp: fix build with automake 1.12
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-support/gmp')
-rw-r--r--meta/recipes-support/gmp/gmp/gmp_fix_for_automake-1.12.patch48
-rw-r--r--meta/recipes-support/gmp/gmp_5.0.4.bb6
2 files changed, 52 insertions, 2 deletions
diff --git a/meta/recipes-support/gmp/gmp/gmp_fix_for_automake-1.12.patch b/meta/recipes-support/gmp/gmp/gmp_fix_for_automake-1.12.patch
new file mode 100644
index 0000000000..8ff1bcfad2
--- /dev/null
+++ b/meta/recipes-support/gmp/gmp/gmp_fix_for_automake-1.12.patch
@@ -0,0 +1,48 @@
+Upstream-Status: Pending
+
+automake 1.12 has depricated automatic de-ANSI-fication support
+
+this patch avoids these kinds of errors:
+
+| configure.in:2240: error: automatic de-ANSI-fication support has been removed
+| Makefile.am:28: error: automatic de-ANSI-fication support has been removed
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/05/02
+
+Index: gmp-5.0.4/configure.in
+===================================================================
+--- gmp-5.0.4.orig/configure.in
++++ gmp-5.0.4/configure.in
+@@ -59,7 +59,7 @@ dnl
+ dnl Note that there's a copy of these options in the top-level Makefile.am,
+ dnl so update there too if changing anything.
+ dnl
+-AM_INIT_AUTOMAKE([1.8 gnu no-dependencies $(top_builddir)/ansi2knr])
++AM_INIT_AUTOMAKE([1.8 gnu no-dependencies])
+ AM_CONFIG_HEADER(config.h:config.in)
+ AM_MAINTAINER_MODE
+
+@@ -2236,9 +2236,6 @@ fi
+ echo " MPN_PATH=\"$path\""
+
+
+-# Automake ansi2knr support.
+-AM_C_PROTOTYPES
+-
+ CL_AS_NOEXECSTACK
+
+ GMP_PROG_AR
+Index: gmp-5.0.4/Makefile.am
+===================================================================
+--- gmp-5.0.4.orig/Makefile.am
++++ gmp-5.0.4/Makefile.am
+@@ -25,7 +25,7 @@
+ # Makefiles in subdirectories, but here we must omit it so automake gives
+ # the actual ansi2knr build rule, not "cd $(top_builddir) && make ansi2knr".
+ #
+-AUTOMAKE_OPTIONS = 1.8 gnu no-dependencies ansi2knr
++AUTOMAKE_OPTIONS = 1.8 gnu no-dependencies
+
+
+ # Libtool -version-info for libgmp.la and libmp.la. See "Versioning" in the
diff --git a/meta/recipes-support/gmp/gmp_5.0.4.bb b/meta/recipes-support/gmp/gmp_5.0.4.bb
index 9adcc3f445..cb2ca5b983 100644
--- a/meta/recipes-support/gmp/gmp_5.0.4.bb
+++ b/meta/recipes-support/gmp/gmp_5.0.4.bb
@@ -2,10 +2,12 @@ require gmp.inc
LICENSE="LGPLv3&GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://version.c;endline=18;md5=d8c56b52b9092346b9f93b4da65ef790"
-PR = "r0"
+PR = "r1"
SRC_URI_append += "file://use-includedir.patch \
- file://gmp_fix_for_x32.patch"
+ file://gmp_fix_for_x32.patch \
+ file://gmp_fix_for_automake-1.12.patch \
+ "
export CC_FOR_BUILD = "${BUILD_CC}"