summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libfm
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-02-02 19:38:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:39 +0000
commit3574375deb31e61bc464a51d8a6b949b8521a4ff (patch)
tree822caee4f7d044470271a118782035f39f1b1567 /meta/recipes-support/libfm
parentf4a00893a4209330720c0366ddde6b9941ee3196 (diff)
downloadopenembedded-core-3574375deb31e61bc464a51d8a6b949b8521a4ff.tar.gz
libfm: add a patch to fix build errors with recent versions of gtk-doc
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libfm')
-rw-r--r--meta/recipes-support/libfm/libfm/0001-Enclose-text-in-programlisting-into-CDATA.patch76
-rw-r--r--meta/recipes-support/libfm/libfm_1.2.5.bb4
2 files changed, 79 insertions, 1 deletions
diff --git a/meta/recipes-support/libfm/libfm/0001-Enclose-text-in-programlisting-into-CDATA.patch b/meta/recipes-support/libfm/libfm/0001-Enclose-text-in-programlisting-into-CDATA.patch
new file mode 100644
index 0000000000..40e53291e1
--- /dev/null
+++ b/meta/recipes-support/libfm/libfm/0001-Enclose-text-in-programlisting-into-CDATA.patch
@@ -0,0 +1,76 @@
+From ed4ca8c0b17ff5d3c768b92409c1787e3f3f1841 Mon Sep 17 00:00:00 2001
+From: Andriy Grytsenko <andrej@rep.kiev.ua>
+Date: Sun, 26 Nov 2017 22:30:15 +0200
+Subject: [PATCH 2/2] Enclose text in <programlisting> into <![CDATA[
+
+New gtk-doc fails on tag-like data in it.
+See https://bugs.freedesktop.org/show_bug.cgi?id=101585
+That is definitely bug of gtk-doc but let workaround it.
+
+Upstream-Status: Backport [https://git.lxde.org/gitweb/?p=lxde/libfm.git;a=commit;h=b072ee0400432d72fdf86ba9fed74a7e0ec11ec1]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ src/base/fm-module.c | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/src/base/fm-module.c b/src/base/fm-module.c
+index d364b2d..2e8c978 100644
+--- a/src/base/fm-module.c
++++ b/src/base/fm-module.c
+@@ -44,7 +44,7 @@
+ * of that type should include:
+ * <example id="example-fm-dummy-h">
+ * <title>Sample of fm-dummy.h</title>
+- * <programlisting>
++ * <programlisting><![CDATA[
+ * #include <libfm/fm.h>
+ *
+ * #define FM_MODULE_dummy_VERSION 1
+@@ -54,7 +54,7 @@
+ * } FmDummyInit;
+ *
+ * extern FmDummyInit fm_module_init_dummy;
+- * </programlisting>
++ * ]]></programlisting>
+ * </example>
+ * The FM_MODULE_dummy_VERSION is a number which should be increased each
+ * time something in FmDummyInit structure is changed. The FmDummyInit
+@@ -65,7 +65,7 @@
+ * module handling in your code:
+ * <example id="example-fm-dummy-widget-c">
+ * <title>Sample of fm-dummy-widget.c</title>
+- * <programlisting>
++ * <programlisting><![CDATA[
+ * #include "fm-dummy.h"
+ *
+ * FM_MODULE_DEFINE_TYPE(dummy, FmDummyInit, 1)
+@@ -87,7 +87,7 @@
+ * result = module->get_new("test sample");
+ * return result;
+ * }
+- * </programlisting>
++ * ]]></programlisting>
+ * </example>
+ *
+ * Third thing application should do is to register module type on the
+@@ -108,7 +108,7 @@
+ * interface (see the fm-dummy.h header example above):
+ * <example id="example-fm-dummy-test-c">
+ * <title>Sample of module dummy/test</title>
+- * <programlisting>
++ * <programlisting><![CDATA[
+ * #include "fm-dummy.h"
+ *
+ * FM_DEFINE_MODULE(dummy, test)
+@@ -121,7 +121,7 @@
+ * FmDummyInit fm_module_init_dummy = {
+ * fm_dummy_test_get_new;
+ * };
+- * </programlisting>
++ * ]]></programlisting>
+ * </example>
+ * The fm_module_init_dummy should be exactly the same structure that is
+ * defined in the header file above.
+--
+2.15.1
+
diff --git a/meta/recipes-support/libfm/libfm_1.2.5.bb b/meta/recipes-support/libfm/libfm_1.2.5.bb
index 6844243c1e..c1deea6853 100644
--- a/meta/recipes-support/libfm/libfm_1.2.5.bb
+++ b/meta/recipes-support/libfm/libfm_1.2.5.bb
@@ -12,7 +12,9 @@ SECTION = "x11/libs"
DEPENDS = "glib-2.0 pango gtk+3 menu-cache intltool-native libexif libfm-extra gettext-native"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz \
- file://0001-Correctly-check-the-stamp-file-that-indicates-if-we-.patch"
+ file://0001-Correctly-check-the-stamp-file-that-indicates-if-we-.patch \
+ file://0001-Enclose-text-in-programlisting-into-CDATA.patch \
+ "
SRC_URI[md5sum] = "a1ba9ae5e920f38b647dd511edd6c807"
SRC_URI[sha256sum] = "c706bb1020cf5f2d6f5a9226f692ce1985947134dcf2bde64278bd0420779b5a"