aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-01-08 12:19:39 -0200
committerSaul Wold <sgw@linux.intel.com>2013-01-09 16:40:36 -0800
commit5de138939c42b0a6d80732130b2617fd60a7d545 (patch)
tree34c43d7dc5c603952a6ca9803279a1b2bf341664 /meta/recipes-support/libnl/libnl
parent3ed5082fd29d2e812f5b4bdda7f6105db25a2e7a (diff)
downloadopenembedded-core-5de138939c42b0a6d80732130b2617fd60a7d545.tar.gz
libnl: Update to 3.2.18
This release fixes the build failures found when building against old Linux kernel headers and also includes the fix for to use 'flex' instead of 'lex'. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/libnl/libnl')
-rw-r--r--meta/recipes-support/libnl/libnl/fix-build-using-flex.patch55
-rw-r--r--meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch2
2 files changed, 1 insertions, 56 deletions
diff --git a/meta/recipes-support/libnl/libnl/fix-build-using-flex.patch b/meta/recipes-support/libnl/libnl/fix-build-using-flex.patch
deleted file mode 100644
index 89a36bafbd..0000000000
--- a/meta/recipes-support/libnl/libnl/fix-build-using-flex.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 89ab8d4f1229a1d2605193686cc00e6b2c9786ff Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Mon, 7 Jan 2013 15:44:38 -0200
-Subject: [PATCH] Fix build using flex
-
-Upstream-Status: Backport [3.2.17]
----
- lib/Makefile.am | 4 ++--
- src/lib/Makefile.am | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/lib/Makefile.am b/lib/Makefile.am
-index 98c7b90..89cc5d2 100644
---- a/lib/Makefile.am
-+++ b/lib/Makefile.am
-@@ -43,14 +43,14 @@ CLEANFILES = \
- route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
- route/pktloc_grammar.h: route/pktloc_grammar.c
- route/pktloc_grammar.c: route/pktloc_grammar.l
-- $(AM_V_GEN) $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
-+ $(AM_V_GEN) $(FLEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
-
- route/pktloc_syntax.h: route/pktloc_syntax.c
- route/pktloc_syntax.c: route/pktloc_syntax.y
- $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
-
- route/cls/ematch_grammar.c: route/cls/ematch_grammar.l
-- $(AM_V_GEN) $(LEX) --header-file=route/cls/ematch_grammar.h $(LFLAGS) -o $@ $^
-+ $(AM_V_GEN) $(FLEX) --header-file=route/cls/ematch_grammar.h $(LFLAGS) -o $@ $^
-
- route/cls/ematch_syntax.c: route/cls/ematch_syntax.y
- $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
-diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
-index 6688e7c..507635d 100644
---- a/src/lib/Makefile.am
-+++ b/src/lib/Makefile.am
-@@ -11,13 +11,13 @@ AM_LDFLAGS = \
- #cls_ematch_cmp_la_LDFLAGS = -module -version-info 2:0:0
-
- #cls/ematch_grammar.c: cls/ematch_grammar.l
--# $(LEX) --header-file=cls/ematch_grammar.h $(LFLAGS) -o $@ $^
-+# $(FLEX) --header-file=cls/ematch_grammar.h $(LFLAGS) -o $@ $^
-
- #cls/ematch_syntax.c: cls/ematch_syntax.y
- # $(YACC) -d $(YFLAGS) -o $@ $^
-
- #cls/pktloc_grammar.c: cls/pktloc_grammar.l
--# $(LEX) --header-file=cls/pktloc_grammar.h $(LFLAGS) -o $@ $^
-+# $(FLEX) --header-file=cls/pktloc_grammar.h $(LFLAGS) -o $@ $^
-
- #cls/pktloc_syntax.c: cls/pktloc_syntax.y
- # $(YACC) -d $(YFLAGS) -o $@ $^
---
-1.7.10.4
-
diff --git a/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch b/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
index 332ec0101d..b93d97b1b7 100644
--- a/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
+++ b/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
@@ -17,7 +17,7 @@ Index: libnl-3.2.14/lib/Makefile.am
+route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
+route/pktloc_grammar.h: route/pktloc_grammar.c
route/pktloc_grammar.c: route/pktloc_grammar.l
- $(AM_V_GEN) $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+ $(AM_V_GEN) $(FLEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+route/pktloc_syntax.h: route/pktloc_syntax.c
route/pktloc_syntax.c: route/pktloc_syntax.y