aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libproxy
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-09 16:34:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 12:27:27 +0000
commit71382cb226129c7991a82e37f3e8723042608546 (patch)
tree2fb24311e33faef49e4b696810425c1e41421e1f /meta/recipes-support/libproxy
parentb06b37162224e945956f0a5d2fe3de2e905ec317 (diff)
downloadopenembedded-core-71382cb226129c7991a82e37f3e8723042608546.tar.gz
libproxy: remove GPLv3 logic and spurious exports
The GPLv3 logic was added back when gnome-common was GPLv3 but that has since been fixed so the logic can be removed. Also remove the export of HOST_SYS and BUILD_SYS (added in 397793) as cmake works fine without them. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libproxy')
-rw-r--r--meta/recipes-support/libproxy/libproxy_0.4.11.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/meta/recipes-support/libproxy/libproxy_0.4.11.bb b/meta/recipes-support/libproxy/libproxy_0.4.11.bb
index 11a23b143f..8cc90bb8e7 100644
--- a/meta/recipes-support/libproxy/libproxy_0.4.11.bb
+++ b/meta/recipes-support/libproxy/libproxy_0.4.11.bb
@@ -17,11 +17,7 @@ SRC_URI[sha256sum] = "dc3f33de54163718f82b3e7c496a7de97f8862578414b8ecaad3cbfe48
inherit cmake pkgconfig
-PACKAGECONFIG ?= " \
- ${@ '' if incompatible_license_contains('GPLv3', 'x', '', d) == 'x' or bb.utils.contains('DISTRO_FEATURES', 'x11', 'x', '', d) == '' else 'gnome' } \
- gnome3 \
-"
-
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gnome', '', d)} gnome3"
PACKAGECONFIG[gnome] = "-DWITH_GNOME=yes,-DWITH_GNOME=no,gconf"
PACKAGECONFIG[gnome3] = "-DWITH_GNOME3=yes,-DWITH_GNOME3=no"
@@ -36,10 +32,5 @@ EXTRA_OECMAKE += " \
-DLIBEXEC_INSTALL_DIR=${libexecdir} \
"
-do_configure_prepend() {
- export HOST_SYS=${HOST_SYS}
- export BUILD_SYS=${BUILD_SYS}
-}
-
FILES_${PN} += "${libdir}/${BPN}/${PV}/modules"
FILES_${PN}-dev += "${datadir}/cmake"