aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libproxy
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-18 00:18:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-18 00:31:24 +0100
commit973351cf2e338f07c11395d494193e9c62857f2d (patch)
tree5e3735fe7fb010eaf10cdc9d73136af33da8eb88 /meta/recipes-support/libproxy
parentdc0fe3fbf9ca862c1d0d90468e6da326f58e3b41 (diff)
downloadopenembedded-core-973351cf2e338f07c11395d494193e9c62857f2d.tar.gz
libproxy: remove dependency on gconf when x11 not in DISTRO_FEATURES
This allows libzypp to successfully build when x11 is not in DISTRO_FEATURES (avoiding the libzypp -> libproxy -> gconf -> gtk+ dependency chain which without X results in gtk+ failing at do_configure). Fixes [YOCTO #2320]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libproxy')
-rw-r--r--meta/recipes-support/libproxy/libproxy_0.4.7.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/libproxy/libproxy_0.4.7.bb b/meta/recipes-support/libproxy/libproxy_0.4.7.bb
index 11b2abfe51..6d998618d8 100644
--- a/meta/recipes-support/libproxy/libproxy_0.4.7.bb
+++ b/meta/recipes-support/libproxy/libproxy_0.4.7.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7d7044444a7b1b116e8783edcdb44ff4 \
DEPENDS = "gconf"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz \
file://g++-namepace.patch \
@@ -31,7 +31,7 @@ do_configure_prepend() {
}
python() {
- if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
+ if base_contains("INCOMPATIBLE_LICENSE", "GPLv3", "x", "", d) == "x" or base_contains("DISTRO_FEATURES", "x11", "x", "", d) == "":
d.setVar("EXTRA_OECMAKE", d.getVar("EXTRA_OECMAKE").replace("-DWITH_GNOME=yes", "-DWITH_GNOME=no"))
d.setVar("DEPENDS", " ".join(i for i in d.getVar("DEPENDS").split() if i != "gconf"))
}