aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2012-12-19 17:18:28 +0100
committerSaul Wold <sgw@linux.intel.com>2012-12-25 14:00:20 -0800
commitda25002a0968c12f16719f9fed21c76b9321aeb5 (patch)
tree563826c5c2d95f9daae8769fef9f7bb607ec7dd8 /meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
parent6f92e7f8891008dd3c89325d3fbe2da853372326 (diff)
downloadopenembedded-core-da25002a0968c12f16719f9fed21c76b9321aeb5.tar.gz
New package: ptest-runner
This package contains a simple shell script which searches for all installed ptests on the rootfs and runs each test in sequence. Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_1.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
new file mode 100644
index 0000000000..6b866d4de2
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
@@ -0,0 +1,17 @@
+SRC_URI += "file://ptest-runner"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_install () {
+ mkdir -p ${D}${bindir}
+ install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir}
+}
+
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+do_build[noexec] = "1"