aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/source-highlight/source-highlight_3.1.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-07-13 17:44:27 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 12:09:51 +0100
commit380f449bc1881a6e8592463c7eeda3655efb97ea (patch)
treed48cebbde385a555bfb017a42bb3903500e2321a /meta/recipes-support/source-highlight/source-highlight_3.1.8.bb
parenteab91997d415b0e690b3482749a32087e6a8b00a (diff)
downloadopenembedded-core-380f449bc1881a6e8592463c7eeda3655efb97ea.tar.gz
source-highlight: add a recipe
gtk-doc relies on this to highlight source code snippets Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/source-highlight/source-highlight_3.1.8.bb')
-rw-r--r--meta/recipes-support/source-highlight/source-highlight_3.1.8.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/source-highlight/source-highlight_3.1.8.bb b/meta/recipes-support/source-highlight/source-highlight_3.1.8.bb
new file mode 100644
index 0000000000..37d2fa95f3
--- /dev/null
+++ b/meta/recipes-support/source-highlight/source-highlight_3.1.8.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Syntax highlight utility"
+DESCRIPTION = "Source-highlight converts source code to formatted text with syntax highlighting."
+HOMEPAGE = "https://www.gnu.org/software/src-highlite/"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ff95bfe019feaf92f524b73dd79e76eb"
+
+SRC_URI = "${GNU_MIRROR}/src-highlite/${BPN}-${PV}.tar.gz \
+ file://0001-source-highlight.pc.in-do-not-add-Boost-s-libraries-.patch"
+SRC_URI[md5sum] = "3243470706ef5fefdc3e43b5306a4e41"
+SRC_URI[sha256sum] = "01336a7ea1d1ccc374201f7b81ffa94d0aecb33afc7d6903ebf9fbf33a55ada3"
+
+inherit autotools
+
+DEPENDS_append = " boost"
+
+DEPENDS_append_class-target = " source-highlight-native"
+
+EXTRA_OECONF = "--with-boost=${PKG_CONFIG_SYSROOT_DIR}/${prefix}"
+
+BBCLASSEXTEND = "native"
+
+# source-highlight is using its own binary from the build tree to make documentation
+# let's substitute the native binary instead
+do_configure_prepend_class-target () {
+ sed -i -e 's,^SRCHILITEEXE = $(top_builddir).*,SRCHILITEEXE = source-highlight,' ${S}/doc/Makefile.am
+}
+
+RDEPENDS_source-highlight += "bash"