aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/sqlite
diff options
context:
space:
mode:
authorAlex J Lennon <ajlennon@dynamicdevices.co.uk>2013-11-06 18:15:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:24:50 +0000
commit9fb82ebab552d1808bae3b4898dd05022913165b (patch)
treef32834572d8d37ff3f892e73e83989fdad645b56 /meta/recipes-support/sqlite
parent24093e26f246f222c385dc37a2f8cf8b0f183175 (diff)
downloadopenembedded-core-9fb82ebab552d1808bae3b4898dd05022913165b.tar.gz
sqlite3: Add support for column metadata API
I found that Mono.Data.SQlite has a dependency on the column meta-data API, thus enabling this API enables use of Hibernate / Mono with SQLite and no doubt enables other ORMs / utility libraries. ref: https://bugzilla.xamarin.com/show_bug.cgi?id=6333 The API is present in the used SQLite3 sqlite-autoconf-3080002 source-base. Thus we are enabling pre-existing SQLite support rather than introducing new code. I am not aware of any issues that enabling this SQLite functionality introduces, other than a slightly increased library size of circa 1.5KB , i.e. coretexa9_vfp_neon i.MX6 - with column meta-data API 610360 libsqlite3.so.0.8.6 - without column meta-data API 608880 libsqlite3.so.0.8.6 Signed-off-by: Alex J Lennon <ajlennon@dynamicdevices.co.uk> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/sqlite')
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3080002.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3_3080002.bb b/meta/recipes-support/sqlite/sqlite3_3080002.bb
index 91dc6dd49b..18ff292fc1 100644
--- a/meta/recipes-support/sqlite/sqlite3_3080002.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3080002.bb
@@ -8,3 +8,8 @@ SRC_URI[md5sum] = "6d6cc639a4da04fbbdda7b1a1a01b386"
SRC_URI[sha256sum] = "fca3a0a12f94dc92a6d9e700c3f6cab6cd4e79214bd7b6f13717a10f4bcfddb2"
S = "${WORKDIR}/sqlite-autoconf-${PV}"
+
+# Provide column meta-data API
+BUILD_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA"
+TARGET_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA"
+