aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/sqlite
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-22 17:25:59 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 10:55:44 +0000
commitc6f91029a05f41cba31702b88316ea66a719e866 (patch)
tree556351a40d0e413dd5ac61081587ddf806f1897f /meta/recipes-support/sqlite
parentbf6372fc361e7588e95f682103332d7a7159c851 (diff)
downloadopenembedded-core-c6f91029a05f41cba31702b88316ea66a719e866.tar.gz
sqlite3: fix the parallel build fix patch
The previous parallel.patch broke dynamically linking sqlite3 with libsqlite3.so (ie using the --disable-static-shell configure option). Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/sqlite')
-rw-r--r--meta/recipes-support/sqlite/sqlite3/parallel.patch46
1 files changed, 27 insertions, 19 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3/parallel.patch b/meta/recipes-support/sqlite/sqlite3/parallel.patch
index 87471f0615..7b886a6bca 100644
--- a/meta/recipes-support/sqlite/sqlite3/parallel.patch
+++ b/meta/recipes-support/sqlite/sqlite3/parallel.patch
@@ -1,24 +1,32 @@
-build: Fix parallel build problems
+From 140476c3e6a6f497bdd95c0c039cb9a680f5a414 Mon Sep 17 00:00:00 2001
+From: Andre McCurdy <armccurdy@gmail.com>
+Date: Fri, 22 Jan 2016 15:53:04 -0800
+Subject: [PATCH] parallel build fix
-Avoid parallel build errors related to sqlite3.o target.
+When statically linking the sqlite3 binary, ensure that it depends on
+its own version of sqlite3.o, instead of the version being built (in
+parallel) for use in the libsqlite3.a static library.
Upstream-Status: Pending
-Signed-off-by: Maxin B. John <maxin.john@intel.com>
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
---
-diff -Naur sqlite-autoconf-3100000-orig/Makefile.am sqlite-autoconf-3100000/Makefile.am
---- sqlite-autoconf-3100000-orig/Makefile.am 2016-01-06 14:03:00.000000000 +0200
-+++ sqlite-autoconf-3100000/Makefile.am 2016-01-12 13:14:03.620117514 +0200
-@@ -6,10 +6,8 @@
- libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8
-
- bin_PROGRAMS = sqlite3
--sqlite3_SOURCES = shell.c sqlite3.h
--EXTRA_sqlite3_SOURCES = sqlite3.c
--sqlite3_LDADD = @EXTRA_SHELL_OBJ@ @READLINE_LIBS@
--sqlite3_DEPENDENCIES = @EXTRA_SHELL_OBJ@
-+sqlite3_SOURCES = shell.c sqlite3.c sqlite3.h
-+sqlite3_LDADD = @READLINE_LIBS@
- sqlite3_CFLAGS = $(AM_CFLAGS)
-
- include_HEADERS = sqlite3.h sqlite3ext.h
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index e9b3950..0e8f043 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -129,7 +129,7 @@ AC_ARG_ENABLE(static-shell, [AS_HELP_STRING(
+ [statically link libsqlite3 into shell tool [default=yes]])],
+ [], [enable_static_shell=yes])
+ if test x"$enable_static_shell" == "xyes"; then
+- EXTRA_SHELL_OBJ=sqlite3.$OBJEXT
++ EXTRA_SHELL_OBJ=sqlite3-sqlite3.$OBJEXT
+ else
+ EXTRA_SHELL_OBJ=libsqlite3.la
+ fi
+--
+1.9.1
+