summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2019-05-18 14:34:13 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-21 12:56:16 +0100
commita9f62ea2c380375c749a28405708bfdb7754f51f (patch)
tree4976b185bc80817ef3b3faed67581324c43af1dc /meta/recipes-support/vim
parent55cc8c6dbef8de240f63e7274a2beaf421124b58 (diff)
downloadopenembedded-core-a9f62ea2c380375c749a28405708bfdb7754f51f.tar.gz
vim: Rework things so vim adds features not vim-tiny removes
Now that we have a common inc file for both vim and vim-tiny move a few bits of logic out of vim.inc and in to vim_$VER.bb so that vim adds things rather than vim-tiny removes them. Suggested-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vim')
-rw-r--r--meta/recipes-support/vim/vim-tiny_8.1.1240.bb3
-rw-r--r--meta/recipes-support/vim/vim.inc8
-rw-r--r--meta/recipes-support/vim/vim_8.1.1240.bb9
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-support/vim/vim-tiny_8.1.1240.bb b/meta/recipes-support/vim/vim-tiny_8.1.1240.bb
index 139e626e44..e4c26d23f6 100644
--- a/meta/recipes-support/vim/vim-tiny_8.1.1240.bb
+++ b/meta/recipes-support/vim/vim-tiny_8.1.1240.bb
@@ -2,9 +2,6 @@ require vim.inc
SUMMARY += " (with tiny features)"
-PROVIDES_remove = "xxd"
-ALTERNATIVE_${PN}_remove = "xxd"
-
PACKAGECONFIG += "tiny"
do_install() {
diff --git a/meta/recipes-support/vim/vim.inc b/meta/recipes-support/vim/vim.inc
index f5c74684bf..433f233448 100644
--- a/meta/recipes-support/vim/vim.inc
+++ b/meta/recipes-support/vim/vim.inc
@@ -1,7 +1,6 @@
SUMMARY = "Vi IMproved - enhanced vi editor"
SECTION = "console/utils"
-PROVIDES = "xxd"
DEPENDS = "ncurses gettext-native"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
@@ -52,7 +51,6 @@ PACKAGECONFIG += " \
${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtkgui', '', d)} \
"
-PACKAGECONFIG_class-native = ""
PACKAGECONFIG[gtkgui] = "--enable-gui=gtk2,--enable-gui=no,gtk+,"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
@@ -130,12 +128,8 @@ RDEPENDS_${BPN} = "ncurses-terminfo-base"
# Recommend that runtime data is installed along with vim
RRECOMMENDS_${BPN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
-ALTERNATIVE_${PN} = "vi vim xxd"
+ALTERNATIVE_${PN} = "vi vim"
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_TARGET = "${bindir}/${BPN}.${BPN}"
ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi"
ALTERNATIVE_LINK_NAME[vim] = "${bindir}/vim"
-ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
-ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"
-
-BBCLASSEXTEND = "native"
diff --git a/meta/recipes-support/vim/vim_8.1.1240.bb b/meta/recipes-support/vim/vim_8.1.1240.bb
index baaaacc0b7..60946a181f 100644
--- a/meta/recipes-support/vim/vim_8.1.1240.bb
+++ b/meta/recipes-support/vim/vim_8.1.1240.bb
@@ -1 +1,10 @@
require vim.inc
+
+PROVIDES = "xxd"
+
+PACKAGECONFIG_class-native = ""
+BBCLASSEXTEND = "native"
+
+ALTERNATIVE_${PN}_append = " xxd"
+ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
+ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"