summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/xxhash
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-03-19 09:43:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-20 18:50:05 +0000
commitfc0c7b68eda2d47ff7ec61f9f49137fb547d9d6b (patch)
treefc4ab1466ede3143ae9ae36c309ffe5063dd2c97 /meta/recipes-support/xxhash
parent88778afc693d824cc637011e91d4727f8e8c2de4 (diff)
downloadopenembedded-core-fc0c7b68eda2d47ff7ec61f9f49137fb547d9d6b.tar.gz
xxhash: import from meta-oe
This is needed for newer versions of apt. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/xxhash')
-rw-r--r--meta/recipes-support/xxhash/xxhash_0.8.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-support/xxhash/xxhash_0.8.0.bb b/meta/recipes-support/xxhash/xxhash_0.8.0.bb
new file mode 100644
index 0000000000..9e38872361
--- /dev/null
+++ b/meta/recipes-support/xxhash/xxhash_0.8.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Extremely fast non-cryptographic hash algorithm"
+DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
+working at speeds close to RAM limits."
+HOMEPAGE = "http://www.xxhash.com/"
+LICENSE = "BSD-2-Clause & GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b335320506abb0505437e39295e799cb"
+
+SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=git"
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+
+SRCREV = "94e5f23e736f2bb67ebdf90727353e65344f9fc0"
+
+S = "${WORKDIR}/git"
+
+do_compile () {
+ oe_runmake all
+}
+
+do_install () {
+ oe_runmake DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native nativesdk"