aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-27 18:01:44 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-28 14:00:21 +0000
commit006b8a7808a58713af16c326dc37d07765334b12 (patch)
tree7fb385008db2170db8de182851c26e1156944de1 /meta/recipes-support
parent9d796611afc42bea5ad9cab47ba4fb5ac0cb5ddd (diff)
downloadopenembedded-core-006b8a7808a58713af16c326dc37d07765334b12.tar.gz
autotools-brokensep: Mark recipes with broken separate build dir support
This patch goes through the OE-Core recipes and marks those which use autotools but don't support a separate build directory (${S} != ${B}). A new class, autotools-brokensep is used for this purpose. This doesn't introduce any change in behaviour in its own right. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/apr/apr-util_1.5.2.bb2
-rw-r--r--meta/recipes-support/apr/apr_1.4.8.bb2
-rw-r--r--meta/recipes-support/aspell/aspell_0.60.6.1.bb2
-rw-r--r--meta/recipes-support/attr/ea-acl.inc2
-rw-r--r--meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2014.1.bb2
-rw-r--r--meta/recipes-support/gnutls/gnutls.inc2
-rw-r--r--meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb2
-rw-r--r--meta/recipes-support/libcroco/libcroco_0.6.8.bb2
-rw-r--r--meta/recipes-support/libfm/libfm_1.1.2.2.bb2
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt.inc2
-rw-r--r--meta/recipes-support/libnl/libnl_3.2.22.bb2
-rw-r--r--meta/recipes-support/nspr/nspr_4.10.3.bb2
12 files changed, 12 insertions, 12 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.2.bb b/meta/recipes-support/apr/apr-util_1.5.2.bb
index 65f26b3c32..4546b9791b 100644
--- a/meta/recipes-support/apr/apr-util_1.5.2.bb
+++ b/meta/recipes-support/apr/apr-util_1.5.2.bb
@@ -28,7 +28,7 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
--with-expat=${STAGING_DIR_HOST}${prefix}"
-inherit autotools lib_package binconfig
+inherit autotools-brokensep lib_package binconfig
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
diff --git a/meta/recipes-support/apr/apr_1.4.8.bb b/meta/recipes-support/apr/apr_1.4.8.bb
index 4af2a6b0c7..4d36585a3e 100644
--- a/meta/recipes-support/apr/apr_1.4.8.bb
+++ b/meta/recipes-support/apr/apr_1.4.8.bb
@@ -19,7 +19,7 @@ SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
SRC_URI[md5sum] = "ce2ab01a0c3cdb71cf0a6326b8654f41"
SRC_URI[sha256sum] = "61b8d2f8d321c6365ee3d71d0bb41f3a89c44da6124cc5b407a3b8319d660421"
-inherit autotools lib_package binconfig multilib_header ptest
+inherit autotools-brokensep lib_package binconfig multilib_header ptest
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
diff --git a/meta/recipes-support/aspell/aspell_0.60.6.1.bb b/meta/recipes-support/aspell/aspell_0.60.6.1.bb
index 86fcc93fca..8ac8809a06 100644
--- a/meta/recipes-support/aspell/aspell_0.60.6.1.bb
+++ b/meta/recipes-support/aspell/aspell_0.60.6.1.bb
@@ -23,4 +23,4 @@ FILES_libpspell = "${libdir}/libpspell.so.*"
FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
ARM_INSTRUCTION_SET = "arm"
-inherit autotools gettext
+inherit autotools-brokensep gettext
diff --git a/meta/recipes-support/attr/ea-acl.inc b/meta/recipes-support/attr/ea-acl.inc
index bcc7acc745..785ce0cf50 100644
--- a/meta/recipes-support/attr/ea-acl.inc
+++ b/meta/recipes-support/attr/ea-acl.inc
@@ -3,7 +3,7 @@
SRC_URI += "file://relative-libdir.patch;striplevel=0 \
"
-inherit autotools gettext
+inherit autotools-brokensep gettext
# the package comes with a custom config.h.in, it cannot be
# overwritten by autoheader
diff --git a/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2014.1.bb b/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2014.1.bb
index 30ca808134..146a02ac7d 100644
--- a/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2014.1.bb
+++ b/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2014.1.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
DEPENDS = "glib-2.0"
-inherit autotools pkgconfig
+inherit autotools-brokensep pkgconfig
PACKAGECONFIG ??= ""
PACKAGECONFIG[journald] = "--with-systemd-journal,--without-systemd-journal,systemd,systemd"
diff --git a/meta/recipes-support/gnutls/gnutls.inc b/meta/recipes-support/gnutls/gnutls.inc
index 18c91eb8cc..39aaec18b5 100644
--- a/meta/recipes-support/gnutls/gnutls.inc
+++ b/meta/recipes-support/gnutls/gnutls.inc
@@ -19,7 +19,7 @@ SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]
SRC_URI = "ftp://ftp.gnutls.org/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.bz2"
-inherit autotools binconfig pkgconfig gettext lib_package
+inherit autotools-brokensep binconfig pkgconfig gettext lib_package
EXTRA_OECONF="--with-included-opencdk --with-included-libcfg --disable-rpath \
--with-libtasn1-prefix=${STAGING_DIR_HOST}${prefix} \
diff --git a/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb b/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
index 78da0bd3f3..e32050446c 100644
--- a/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
+++ b/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
@@ -21,7 +21,7 @@ S = "${WORKDIR}/js/src"
# use local autoconf script to generate a usable jsautocfg.h
# don't bother with automake
-inherit autotools
+inherit autotools-brokensep
do_configure_prepend() {
cp -f ${WORKDIR}/configure.ac ${S}
diff --git a/meta/recipes-support/libcroco/libcroco_0.6.8.bb b/meta/recipes-support/libcroco/libcroco_0.6.8.bb
index 61cd8182f6..385665f0fd 100644
--- a/meta/recipes-support/libcroco/libcroco_0.6.8.bb
+++ b/meta/recipes-support/libcroco/libcroco_0.6.8.bb
@@ -13,7 +13,7 @@ BBCLASSEXTEND = "native"
EXTRA_OECONF += "--enable-Bsymbolic=auto"
PR = "r1"
-inherit autotools pkgconfig gnomebase
+inherit autotools-brokensep pkgconfig gnomebase
GNOME_COMPRESS_TYPE = "xz"
diff --git a/meta/recipes-support/libfm/libfm_1.1.2.2.bb b/meta/recipes-support/libfm/libfm_1.1.2.2.bb
index 581ab8c753..ea6323a831 100644
--- a/meta/recipes-support/libfm/libfm_1.1.2.2.bb
+++ b/meta/recipes-support/libfm/libfm_1.1.2.2.bb
@@ -17,7 +17,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.gz \
SRC_URI[md5sum] = "ea3d09b23ef4c37cb84ae57ea16b8f08"
SRC_URI[sha256sum] = "158e2b6974350d2dab15932b496bb4d448553e60bbf7cdfe4d6e9bd99d19d682"
-inherit autotools pkgconfig
+inherit autotools-brokensep pkgconfig
PACKAGES += "${PN}-mime"
FILES_${PN}-mime = "${datadir}/mime/"
diff --git a/meta/recipes-support/libgcrypt/libgcrypt.inc b/meta/recipes-support/libgcrypt/libgcrypt.inc
index 249939dab9..e7fcc62908 100644
--- a/meta/recipes-support/libgcrypt/libgcrypt.inc
+++ b/meta/recipes-support/libgcrypt/libgcrypt.inc
@@ -14,7 +14,7 @@ SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
file://add-pkgconfig-support.patch \
file://libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch"
-inherit autotools binconfig pkgconfig
+inherit autotools-brokensep binconfig pkgconfig
EXTRA_OECONF = "--disable-asm --with-capabilities"
diff --git a/meta/recipes-support/libnl/libnl_3.2.22.bb b/meta/recipes-support/libnl/libnl_3.2.22.bb
index 73b10c5b66..a299bfbe7b 100644
--- a/meta/recipes-support/libnl/libnl_3.2.22.bb
+++ b/meta/recipes-support/libnl/libnl_3.2.22.bb
@@ -19,7 +19,7 @@ SRC_URI = "http://www.infradead.org/~tgr/${BPN}/files/${BP}.tar.gz \
SRC_URI[md5sum] = "2e1c889494d274aca24ce5f6a748e66e"
SRC_URI[sha256sum] = "c7c5f267dfeae0c1a530bf96b71fb7c8dbbb07d54beef49b6712d8d6166f629b"
-inherit autotools pkgconfig
+inherit autotools-brokensep pkgconfig
FILES_${PN} = "${libdir}/libnl-3.so.* \
${libdir}/libnl.so.* \
diff --git a/meta/recipes-support/nspr/nspr_4.10.3.bb b/meta/recipes-support/nspr/nspr_4.10.3.bb
index 4792b6543b..0adfe3b3a3 100644
--- a/meta/recipes-support/nspr/nspr_4.10.3.bb
+++ b/meta/recipes-support/nspr/nspr_4.10.3.bb
@@ -138,7 +138,7 @@ TESTS = "runtests.pl \
xnotify \
zerolen"
-inherit autotools
+inherit autotools-brokensep
do_configure() {
gnu-configize --force