summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-05-03 18:10:40 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-04 22:48:12 +0100
commit1cb679e6a4528a2cef16f65342d5e65adb14cb16 (patch)
tree31cd268c5fb7ded456c386cb003b954346abb4d8 /meta/recipes-support
parent7ad71de89dd60700cbaad2df1937bc3d743112da (diff)
downloadopenembedded-core-1cb679e6a4528a2cef16f65342d5e65adb14cb16.tar.gz
ptest-runner: libgcc must be installed for pthread_cancel to work
This only affects glibc systems and have been found on runqemu core-image-minimal with gstreamer ptest-runner STOP: ptest-runner libgcc_s.so.1 must be installed for pthread_cancel to work Aborted Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
index 57a3ae005b..6bd10d2fec 100644
--- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
@@ -26,3 +26,5 @@ do_compile () {
do_install () {
install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
}
+
+RDEPENDS_${PN}_append_libc-glibc = " libgcc"