summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJoerg Vehlow <joerg.vehlow@aox.de>2022-05-25 11:26:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-27 23:47:20 +0100
commit32ba67bc37b5ca73f7d29cb6c7de281ab8f824bd (patch)
treea7307bc9f879a0df553e2801eefb1ea587c066e2 /meta/recipes-support
parent7751bc4909f3834e43db020ebb91665a5d7960a9 (diff)
downloadopenembedded-core-32ba67bc37b5ca73f7d29cb6c7de281ab8f824bd.tar.gz
libseccomp: Add missing files for ptests
pfc files are used e.g. in 38-basic-pfc_coverage.sh valgrind_test.supp is required, when valgrind is installed, otherwise all valgrind tests fail Signed-off-by: Joerg Vehlow <joerg.vehlow@aox.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libseccomp/libseccomp_2.5.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
index c76f3c3573..731d9ae08d 100644
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
+++ b/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
@@ -37,6 +37,10 @@ do_install_ptest() {
for file in $(find tests/*.tests -type f); do
install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
done
+ for file in $(find tests/*.pfc -type f); do
+ install -m 644 ${S}/${file} ${D}/${PTEST_PATH}/tests
+ done
+ install -m 644 ${S}/tests/valgrind_test.supp ${D}/${PTEST_PATH}/tests
for file in $(find tools/* -executable -type f); do
install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
done