aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-11-16 03:19:55 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-02-17 14:14:24 +0000
commit42232782b9a3aa0ed03c5dda84fc0b865b74b2dd (patch)
tree5c0dd5c125fe250f27c1bc10f5c901c3ad85620e /meta
parent1aeab422006c5e5b1bffa3fa05669fcb01d7ffdf (diff)
downloadopenembedded-core-42232782b9a3aa0ed03c5dda84fc0b865b74b2dd.tar.gz
subversion: fix build problem when sysroot contains '-D' or '-I'
If sysroot contains '-D' or '-I' characters, the SVN_NEON_INCLUDES and the corresponding CFLAGS will not get the correct value. This will cause build failures. This patch fixes the above problem. [YOCTO #5458] (From OE-Core master rev: 7078397ef39de43244fca7e24683b2a83913cbbf) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/subversion/subversion-1.7.8/neon.m4-fix-includes-and-cflags.patch32
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.7.8.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion-1.7.8/neon.m4-fix-includes-and-cflags.patch b/meta/recipes-devtools/subversion/subversion-1.7.8/neon.m4-fix-includes-and-cflags.patch
new file mode 100644
index 0000000000..013d0c3649
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion-1.7.8/neon.m4-fix-includes-and-cflags.patch
@@ -0,0 +1,32 @@
+Fix to get correct SVN_NEON_CONFIG and CFLAGS when sysroot path contains '-D' and '-I'
+characters.
+
+Upstream-Status: Pending
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+index f951039..a813145 100644
+--- a/build/ac-macros/neon.m4
++++ b/build/ac-macros/neon.m4
+@@ -105,8 +105,8 @@ AC_DEFUN(SVN_NEON_CONFIG,
+ test "$svn_allowed_neon" = "any"; then
+ svn_allowed_neon_on_system="yes"
+ if test "$NEON_PKG_CONFIG" = "yes"; then
+- SVN_NEON_INCLUDES=[`$PKG_CONFIG neon --cflags | $SED -e 's/-D[^ ]*//g'`]
+- CFLAGS=["$CFLAGS `$PKG_CONFIG neon --cflags | $SED -e 's/-I[^ ]*//g'`"]
++ SVN_NEON_INCLUDES=["`$PKG_CONFIG neon --cflags | $SED -e 's/^-D[^ ]*//g' -e 's/ -D[^ ]*//g'`"]
++ CFLAGS=["$CFLAGS `$PKG_CONFIG neon --cflags | $SED -e 's/^-I[^ ]*//g' -e 's/ -I[^ ]*//g'`"]
+ old_CFLAGS="$CFLAGS"
+ old_LIBS="$LIBS"
+ NEON_LIBS=`$PKG_CONFIG neon --libs`
+@@ -126,8 +126,8 @@ int main()
+ CFLAGS="$old_CFLAGS"
+ LIBS="$old_LIBS"
+ else
+- SVN_NEON_INCLUDES=[`$neon_config --cflags | $SED -e 's/-D[^ ]*//g'`]
+- CFLAGS=["$CFLAGS `$neon_config --cflags | $SED -e 's/-I[^ ]*//g'`"]
++ SVN_NEON_INCLUDES=[`$neon_config --cflags | $SED -e 's/^-D[^ ]*//g' -e 's/ -D[^ ]*//g'`]
++ CFLAGS=["$CFLAGS `$neon_config --cflags | $SED -e 's/^-I[^ ]*//g' -e 's/ -I[^ ]*//g'`"]
+ NEON_LIBS=`$neon_config --libs`
+ fi
+ svn_lib_neon="yes"
diff --git a/meta/recipes-devtools/subversion/subversion_1.7.8.bb b/meta/recipes-devtools/subversion/subversion_1.7.8.bb
index 6aced2878d..0e3d844df8 100644
--- a/meta/recipes-devtools/subversion/subversion_1.7.8.bb
+++ b/meta/recipes-devtools/subversion/subversion_1.7.8.bb
@@ -12,6 +12,7 @@ inherit gettext
SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
file://libtool2.patch \
file://fix-install-depends.patch \
+ file://neon.m4-fix-includes-and-cflags.patch \
"
SRC_URI[md5sum] = "454b9f398415c3504435bf8c3f6ed127"
SRC_URI[sha256sum] = "fc83d4d98ccea8b7bfa8f5c20fff545c8baa7d035db930977550c51c6ca23686"