aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-21 16:30:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-21 16:30:37 +0000
commitb60d0c57a2e16d690fd11c6349917efc57630004 (patch)
tree0bb4b4f34631ae21d2ded10dda4d2687952b5b84 /meta
parent7a98c0ef28822ae1fcee45b14db3edcfd4c7ad8f (diff)
downloadopenembedded-core-b60d0c57a2e16d690fd11c6349917efc57630004.tar.gz
gettext/awk/sed/grep: Backport WARNING fixes to GPLv2 versions
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb6
-rw-r--r--meta/recipes-extended/gawk/gawk_3.1.5.bb5
-rw-r--r--meta/recipes-extended/grep/grep_2.5.1a.bb1
-rw-r--r--meta/recipes-extended/sed/sed_4.1.2.bb1
4 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
index 73e5f55f99..0b7dfa30e1 100644
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -31,7 +31,7 @@ PARALLEL_MAKE = ""
inherit autotools
-EXTRA_OECONF += "--without-lisp --disable-csharp --disable-openmp"
+EXTRA_OECONF += "--without-lisp --disable-csharp --disable-openmp --without-emacs"
acpaths = '-I ${S}/autoconf-lib-link/m4/ \
-I ${S}/gettext-runtime/m4 \
-I ${S}/gettext-tools/m4'
@@ -53,3 +53,7 @@ do_configure_prepend() {
PACKAGES =+ "libgettextlib libgettextsrc"
FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
+
+do_install_append() {
+ rm -f ${D}${libdir}/preloadable_libintl.so
+}
diff --git a/meta/recipes-extended/gawk/gawk_3.1.5.bb b/meta/recipes-extended/gawk/gawk_3.1.5.bb
index bd8460d79e..d5d9beaa49 100644
--- a/meta/recipes-extended/gawk/gawk_3.1.5.bb
+++ b/meta/recipes-extended/gawk/gawk_3.1.5.bb
@@ -33,3 +33,8 @@ ALTERNATIVE_NAME = "awk"
ALTERNATIVE_PATH = "gawk"
ALTERNATIVE_LINK = "${bindir}/awk"
ALTERNATIVE_PRIORITY = "100"
+
+do_install_append() {
+ # remove the link since we don't package it
+ rm ${D}${bindir}/awk
+}
diff --git a/meta/recipes-extended/grep/grep_2.5.1a.bb b/meta/recipes-extended/grep/grep_2.5.1a.bb
index bb4f53fb02..64064fc5c6 100644
--- a/meta/recipes-extended/grep/grep_2.5.1a.bb
+++ b/meta/recipes-extended/grep/grep_2.5.1a.bb
@@ -27,6 +27,7 @@ do_install () {
mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+ rmdir ${D}${bindir}/
}
pkg_postinst_${PN} () {
diff --git a/meta/recipes-extended/sed/sed_4.1.2.bb b/meta/recipes-extended/sed/sed_4.1.2.bb
index 713524c41d..8baa180f72 100644
--- a/meta/recipes-extended/sed/sed_4.1.2.bb
+++ b/meta/recipes-extended/sed/sed_4.1.2.bb
@@ -18,6 +18,7 @@ do_install () {
autotools_do_install
install -d ${D}${base_bindir}
mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+ rmdir ${D}${bindir}/
}
ALTERNATIVE_NAME = "sed"