summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorGernot Hillier <gernot.hillier@siemens.com>2017-04-26 12:57:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-10 12:21:34 +0100
commitb07242cfe4544e99daf0a8d2f7062530e366bfae (patch)
tree2baeffbf08fd8a7fe502488bb1cc4201efa34d8c /meta
parent60c9b55d2247ca4a5074804eb42189c31d33fcf8 (diff)
downloadopenembedded-core-b07242cfe4544e99daf0a8d2f7062530e366bfae.tar.gz
tcf-agent: enable default target debugging features
A number of features were disabled in OE due to historic problems on ARM. In tcf-agent 1.4, they compile cleanly on all architectures besides mips and libc-musl. These features are required for target debugging with Eclipse Neon, CDT and TCF plugins - for example used by Xilinx Vivado SDK 2016.4. For MIPS and libc-musl, at least re-enable SERVICE_Symbols and SERVICE_LineNumbers which compile cleanly. Signed-off-by: Gernot Hillier <gernot.hillier@siemens.com> Signed-off-by: Tim Offermann <tim.offermann@siemens.com> Acked-by: Eugene Tarassov <eugene.tarassov@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
index cd0081ac16..1dad825fda 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -35,11 +35,16 @@ MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
-# They don't build on ARM and we don't need them actually.
-CFLAGS += "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+# These features don't compile on mips and libc-musl
+CFLAGS_mips_append = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
-DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
- -DSERVICE_StackTrace=0 -DSERVICE_Symbols=0 -DSERVICE_LineNumbers=0 \
- -DSERVICE_Expressions=0"
+ -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
+CFLAGS_mips64_append = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+ -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
+ -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
+CFLAGS_append_libc-musl = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+ -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
+ -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
do_install() {
oe_runmake install INSTALLROOT=${D}