summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-07 12:17:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-07 12:36:41 +0100
commit4fd4b2eafb5f4ff2ef85d7f5ff3238a41c34313b (patch)
tree8267a60091d6435cbcc322bfe017fbf45452e5b9 /meta
parent447819db343a93bcc1e079c2a33b592da20f6c1e (diff)
downloadopenembedded-core-4fd4b2eafb5f4ff2ef85d7f5ff3238a41c34313b.tar.gz
linux-yocto-3.4: Disable extra slang header search path
Add in a workaround to avoid host infection detection build failures from the slang include directory in perf. I'll defer to Bruce to fix this properly but we need a workaround now as this is breaking builds. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto/noslang.patch20
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb2
2 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto/noslang.patch b/meta/recipes-kernel/linux/linux-yocto/noslang.patch
new file mode 100644
index 0000000000..9cada34d11
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto/noslang.patch
@@ -0,0 +1,20 @@
+We (OE) install slang into /usr/include so we never need to look into
+/usr/include/slang/. We never want to look into a hardcoded path like this
+since it triggers host infection issues. For now, simply remove this
+since it causes us problems.
+
+Upstream-Status: Pending (would need rework)
+
+Index: tools/perf/Makefile
+===================================================================
+--- linux.orig/tools/perf/Makefile 2012-08-07 10:29:43.020149620 +0000
++++ linux/tools/perf/Makefile 2012-08-07 10:30:08.128148098 +0000
+@@ -504,7 +504,7 @@
+ BASIC_CFLAGS += -DNO_NEWT_SUPPORT
+ else
+ # Fedora has /usr/include/slang/slang.h, but ubuntu /usr/include/slang.h
+- BASIC_CFLAGS += -I/usr/include/slang
++ # BASIC_CFLAGS += -I/usr/include/slang
+ EXTLIBS += -lnewt -lslang
+ LIB_OBJS += $(OUTPUT)util/ui/setup.o
+ LIB_OBJS += $(OUTPUT)util/ui/browser.o
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 48333b3e00..5ab46b7a1e 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -20,6 +20,8 @@ SRCREV_meta ?= "7ff48aa47c50b6455d60ca93bc81260ce8fe1a1b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI += "file://noslang.patch"
+
LINUX_VERSION ?= "3.4.6"
PR = "${INC_PR}.0"