summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-03-21 12:37:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-21 22:40:45 +0000
commit721b5a81b176dd0f2aafb2fe3587d28df383eb7b (patch)
treebd42328c190700f55ac2b107f7411ed6b5accf4b /meta
parentdef25193748fac40c4120e9a6e8861ae4c7ae760 (diff)
downloadopenembedded-core-721b5a81b176dd0f2aafb2fe3587d28df383eb7b.tar.gz
python3-markupsafe: use python3-unittest-automake-output
Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-markupsafe/run-ptest2
-rw-r--r--meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-markupsafe/run-ptest b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
index 5cec711696..8d2017d39c 100644
--- a/meta/recipes-devtools/python/python3-markupsafe/run-ptest
+++ b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest
+pytest --automake
diff --git a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
index f4f0ad2df0..3242052963 100644
--- a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
+++ b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
@@ -6,8 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
SRC_URI[sha256sum] = "abcabc8c2b26036d62d4c746381a6f7cf60aafcc653198ad678306986b09450d"
PYPI_PACKAGE = "MarkupSafe"
-inherit pypi setuptools3
-inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
+inherit pypi setuptools3 ptest
RDEPENDS:${PN} += "${PYTHON_PN}-stringold"
@@ -19,6 +18,7 @@ SRC_URI += " \
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unittest-automake-output \
"
do_install_ptest() {