summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-12-14 15:18:56 +0800
committerSaul Wold <sgw@linux.intel.com>2010-12-14 09:46:34 -0800
commite8017dc3cbfc40a03d47ed170518726075937bd3 (patch)
tree33272c39509350cec2cfac18e9450354238311c7 /meta
parent497b759d42bf8126966ce9bdaee729524c21b235 (diff)
downloadopenembedded-core-e8017dc3cbfc40a03d47ed170518726075937bd3.tar.gz
gnome-desktop: add --disable-desktop-docs
autobuilder logs show the below failure: | xsltproc -o lgpl-vi.omf --stringparam db2omf.basename lgpl --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang vi --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in ... | http://www.oasis-open.org/docbook/xml/4.1.2/dbpoolx.mod:632: parser warning : PEReference: %notation.class; not found | ... | unable to parse oc/lgpl.xml | make[3]: *** [lgpl-oc.omf] Error 1 However this issue can't be reproduced in my Ubuntu 9.04 system. I suppose it's because on autobuilder the newer libxml has a stricter syntax requirement about the related xml files. Actually before commit b8b13dcbb76fdc3c9a2866bb35945dcf949c4b20 upgraded gnome-desktop to 2.32.1, we also didn't build desktop-docs. The commit removed no-desktop-docs.patch but didn't notice the Makefile.am depends on --disable-desktop-docs to decice whether desktop-docs will be built. So we should continue to make sure desktop-docs is not built. Fixes [BUGID: 587] Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-gnome/gnome/gnome-desktop.inc7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-desktop.inc b/meta/recipes-gnome/gnome/gnome-desktop.inc
index fb330a5156..123f82da73 100644
--- a/meta/recipes-gnome/gnome/gnome-desktop.inc
+++ b/meta/recipes-gnome/gnome/gnome-desktop.inc
@@ -3,7 +3,7 @@ SECTION = "x11/gnome"
LICENSE = "GPLv2 & LGPLv2"
DEPENDS = "gconf-dbus libxrandr virtual/libx11 gtk+ glib-2.0 gnome-doc-utils"
-EXTRA_OECONF = "--disable-scrollkeeper"
+EXTRA_OECONF = "--disable-scrollkeeper --disable-desktop-docs"
do_configure_prepend () {
cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}
@@ -11,4 +11,7 @@ do_configure_prepend () {
FILES_${PN} += "${datadir}/gnome-about"
-inherit gnome pkgconfig \ No newline at end of file
+PR = "r1"
+
+inherit gnome pkgconfig
+