summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-22 12:09:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-22 11:56:06 +0100
commitf31ae697803bad73052066f7b39317f8a01695d4 (patch)
treefddedbcd7978b7a5ff92542fe522df2c5d91d788 /meta
parentd5a42bb0382243d12388a0e0b18461c58d12c60e (diff)
downloadopenembedded-core-f31ae697803bad73052066f7b39317f8a01695d4.tar.gz
gnome-keyring 2.32.1: fix PAM support and make it conditional on DISTRO_FEATURES
The plugin got installed into the wrong dir leading to: gdm-session-worker[515]: PAM unable to dlopen(/lib/security/pam_gnome_keyring.so): /lib/security/pam_gnome_keyring.so: cannot open shared object file: No such file or directory Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb b/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
index 3f384012eb..cc9722598a 100644
--- a/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
+++ b/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
@@ -11,14 +11,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
SECTION = "x11/gnome"
-PR = "r2"
+PR = "r3"
inherit autotools gnome pkgconfig
-DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf"
+DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
RDEPENDS_${PN} = "libgnome-keyring"
-EXTRA_OECONF = "--disable-gtk-doc"
+EXTRA_OECONF = "--disable-gtk-doc ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
SRC_URI += "file://org.gnome.keyring.service"
@@ -30,6 +30,6 @@ do_install_append () {
install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
}
-FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr ${libdir}/security/*.so"
-FILES_${PN}-dbg += "${libdir}/gnome-keyring/standalone/.debug/"
-FILES_${PN}-dbg += "${libdir}/gnome-keyring/devel/.debug/"
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr ${base_libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/standalone/.debug/ ${base_libdir}/security/*.la"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/devel/.debug/ ${base_libdir}/security/.debug"