aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-connectivity/connman/connman.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index 96ebc551b8..5d35bc2185 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -20,7 +20,7 @@ DEPENDS = "dbus glib-2.0 ppp iptables gnutls \
${@base_contains('DISTRO_FEATURES', '3g','ofono', '', d)} \
"
-INC_PR = "r0"
+INC_PR = "r1"
TIST = "--enable-tist"
TIST_powerpc = ""
@@ -47,6 +47,7 @@ INITSCRIPT_NAME = "connman"
INITSCRIPT_PARAMS = "start 05 5 2 3 . stop 22 0 1 6 ."
SYSTEMD_SERVICE_${PN} = "connman.service"
+SYSTEMD_WIRED_SETUP = "ExecStartPre=-/usr/lib/connman/wired-setup"
# IMPORTANT: because xuser is shared with rootless X, please make sure the
# USERADD_PARAM is in sync with the one in xserver-nodm-init.bb
@@ -57,6 +58,10 @@ USERADD_PARAM_${PN} = "--create-home \
inherit autotools gtk-doc pkgconfig systemd update-rc.d useradd
+do_configure_append () {
+ sed -i "s#ExecStart=#${SYSTEMD_WIRED_SETUP}\nExecStart=#" ${S}/src/connman.service
+}
+
# This allows *everyone* to access ConnMan over DBus, without any access
# control. Really the at_console flag should work, which would mean that
# both this and the xuser patch can be dropped.