summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/systemd/systemd/0022-Use-INT_MAX-instead-of-TIME_T_MAX-for-timerfd_settim.patch31
-rw-r--r--meta/recipes-core/systemd/systemd_244.3.bb3
2 files changed, 1 insertions, 33 deletions
diff --git a/meta/recipes-core/systemd/systemd/0022-Use-INT_MAX-instead-of-TIME_T_MAX-for-timerfd_settim.patch b/meta/recipes-core/systemd/systemd/0022-Use-INT_MAX-instead-of-TIME_T_MAX-for-timerfd_settim.patch
deleted file mode 100644
index 33c575871c..0000000000
--- a/meta/recipes-core/systemd/systemd/0022-Use-INT_MAX-instead-of-TIME_T_MAX-for-timerfd_settim.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 3cc30186f9d9adb565dc29f2d4e68889974676ae Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 16 Dec 2019 12:49:07 -0800
-Subject: [PATCH] Use INT_MAX instead of TIME_T_MAX for timerfd_settime timeout
-
-kernel prior to 64bit time_t support might not entertain such large
-timeout therefore reduce it to INT_MAX which would set timer expiration
-event after 68 years of uptime, should be good for all practical
-purposes
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Pending
-
----
- src/basic/time-util.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/basic/time-util.c b/src/basic/time-util.c
-index d7ef30d2fe52..4d3219f114b5 100644
---- a/src/basic/time-util.c
-+++ b/src/basic/time-util.c
-@@ -1487,7 +1487,7 @@ int time_change_fd(void) {
-
- /* We only care for the cancellation event, hence we set the timeout to the latest possible value. */
- static const struct itimerspec its = {
-- .it_value.tv_sec = TIME_T_MAX,
-+ .it_value.tv_sec = INT_MAX,
- };
-
- _cleanup_close_ int fd;
diff --git a/meta/recipes-core/systemd/systemd_244.3.bb b/meta/recipes-core/systemd/systemd_244.3.bb
index e7d2997963..dfb7ad59c0 100644
--- a/meta/recipes-core/systemd/systemd_244.3.bb
+++ b/meta/recipes-core/systemd/systemd_244.3.bb
@@ -17,9 +17,9 @@ REQUIRED_DISTRO_FEATURES = "systemd"
SRC_URI += "file://touchscreen.rules \
file://00-create-volatile.conf \
file://init \
+ file://99-default.preset \
file://0001-binfmt-Don-t-install-dependency-links-at-install-tim.patch \
file://0003-implment-systemd-sysv-install-for-OE.patch \
- file://99-default.preset \
"
# patches needed by musl
@@ -42,7 +42,6 @@ SRC_URI_MUSL = "\
file://0019-Hide-__start_BUS_ERROR_MAP-and-__stop_BUS_ERROR_MAP.patch \
file://0020-missing_type.h-add-__compar_d_fn_t-definition.patch \
file://0021-avoid-redefinition-of-prctl_mm_map-structure.patch \
- file://0022-Use-INT_MAX-instead-of-TIME_T_MAX-for-timerfd_settim.patch \
file://0024-test-json.c-define-M_PIl.patch \
file://0001-do-not-disable-buffer-in-writing-files.patch \
file://0002-src-login-brightness.c-include-sys-wait.h.patch \