summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb21
1 files changed, 10 insertions, 11 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb
index 3215ff140c..865c1d71ee 100644
--- a/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb
@@ -1,22 +1,14 @@
SUMMARY = "An HTTP library implementation in C"
-HOMEPAGE = "http://www.gnome.org/"
+HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
BUGTRACKER = "https://bugzilla.gnome.org/"
-
+SECTION = "x11/gnome/libs"
LICENSE = "LGPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
-SECTION = "x11/gnome/libs"
-
DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native"
-EXTRA_OECONF = "--disable-vala"
+SHRT_VER = "${@d.getVar('PV', True).split('.')[0]}.${@d.getVar('PV', True).split('.')[1]}"
-# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
-# by default but let it be easily disabled.
-PACKAGECONFIG ??= "gnome"
-PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
-
-SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
SRC_URI[md5sum] = "e4757d09012ed93822b1ee41435fec24"
@@ -26,5 +18,12 @@ S = "${WORKDIR}/libsoup-${PV}"
inherit autotools gettext pkgconfig upstream-version-is-even
+# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
+# by default but let it be easily disabled.
+PACKAGECONFIG ??= "gnome"
+PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
+
+EXTRA_OECONF = "--disable-vala"
+
# glib-networking is needed for SSL, proxies, etc.
RRECOMMENDS_${PN} = "glib-networking"