summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch29
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb (renamed from meta/recipes-devtools/python-numpy/python-numpy_1.10.4.bb)14
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.11.0.bb (renamed from meta/recipes-devtools/python-numpy/python3-numpy_1.10.4.bb)15
3 files changed, 46 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch b/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
new file mode 100644
index 0000000000..6c61b09f65
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Avoids using python from the HOSTs native sysroot for f2py,
+uses TARGET env python instead.
+
+Signed-Off-By: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
+
+Index: numpy-1.11.0/numpy/f2py/setup.py
+===================================================================
+--- numpy-1.11.0.orig/numpy/f2py/setup.py
++++ numpy-1.11.0/numpy/f2py/setup.py
+@@ -37,10 +37,13 @@ def _get_f2py_shebang():
+ should be ``#!python`` rather than ``#!`` followed by the contents of
+ ``sys.executable``.
+ """
+- if set(('bdist_wheel', 'bdist_egg', 'bdist_wininst',
+- 'bdist_rpm')).intersection(sys.argv):
+- return '#!python'
+- return '#!' + sys.executable
++ #if set(('bdist_wheel', 'bdist_egg', 'bdist_wininst',
++ # 'bdist_rpm')).intersection(sys.argv):
++ # return '#!python'
++ #return '#!' + sys.executable
++
++ # On OE, we need to avoid using the HOSTs python-native, we return env python instead
++ return '#!/usr/bin/env python'
+
+
+ def configuration(parent_package='', top_path=None):
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.10.4.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb
index ca6a7abb0e..51ef171052 100644
--- a/meta/recipes-devtools/python-numpy/python-numpy_1.10.4.bb
+++ b/meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb
@@ -1,12 +1,14 @@
SUMMARY = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9f4e88b5748e8313caaf33d081ce65a3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
-SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
+SRCNAME = "numpy"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://remove-build-path-in-comments.patch \
- file://add-glibc-check.patch \
+ file://fix_shebang_f2py.patch \
${CONFIGFILESURI} "
CONFIGFILESURI ?= ""
@@ -58,7 +60,7 @@ CONFIGFILESURI_mips64n32 = " \
S = "${WORKDIR}/numpy-${PV}"
-inherit distutils
+inherit setuptools
# Make the build fail and replace *config.h with proper one
# This is a ugly, ugly hack - Koen
@@ -70,8 +72,8 @@ do_compile_prepend_class-target() {
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
-SRC_URI[md5sum] = "90bb9034652cefbada19cf7d141a6a61"
-SRC_URI[sha256sum] = "f7f91842056a7cf680b0eaf8cefc5e46c69e2521e651128d2e6aaaccec8652ae"
+SRC_URI[md5sum] = "bc56fb9fc2895aa4961802ffbdb31d0b"
+SRC_URI[sha256sum] = "a1d1268d200816bfb9727a7a27b78d8e37ecec2e4d5ebd33eb64e2789e0db43e"
# install what is needed for numpy.test()
RDEPENDS_${PN} = "python-unittest \
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.10.4.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.11.0.bb
index dcd23ac98d..218909bfed 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.10.4.bb
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.11.0.bb
@@ -1,12 +1,14 @@
SUMMARY = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9f4e88b5748e8313caaf33d081ce65a3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
-SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
+SRCNAME = "numpy"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://remove-build-path-in-comments.patch \
- file://add-glibc-check.patch \
+ file://fix_shebang_f2py.patch \
${CONFIGFILESURI} "
CONFIGFILESURI ?= ""
@@ -58,7 +60,7 @@ CONFIGFILESURI_mips64n32 = " \
S = "${WORKDIR}/numpy-${PV}"
-inherit distutils3
+inherit setuptools3
# Make the build fail and replace *config.h with proper one
# This is a ugly, ugly hack - Koen
@@ -70,8 +72,8 @@ do_compile_prepend_class-target() {
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
-SRC_URI[md5sum] = "90bb9034652cefbada19cf7d141a6a61"
-SRC_URI[sha256sum] = "f7f91842056a7cf680b0eaf8cefc5e46c69e2521e651128d2e6aaaccec8652ae"
+SRC_URI[md5sum] = "bc56fb9fc2895aa4961802ffbdb31d0b"
+SRC_URI[sha256sum] = "a1d1268d200816bfb9727a7a27b78d8e37ecec2e4d5ebd33eb64e2789e0db43e"
# install what is needed for numpy.test()
RDEPENDS_${PN} = "python3-unittest \
@@ -94,6 +96,7 @@ RDEPENDS_${PN} = "python3-unittest \
python3-compression \
python3-ctypes \
python3-threading \
+ python3-textutils \
"
RDEPENDS_${PN}_class-native = ""