summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb')
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
new file mode 100644
index 0000000000..fcba0d5662
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPL"
+SECTION = "bootloader"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://fix-arm920t-eabi.patch;patch=1"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+inherit native
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_compile () {
+ oe_runmake smdk2410_config
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}