aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/neard/neard/neard42
-rw-r--r--meta/recipes-connectivity/neard/neard_0.9.bb57
2 files changed, 99 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/neard/neard/neard b/meta/recipes-connectivity/neard/neard/neard
new file mode 100644
index 0000000000..5f36174d62
--- /dev/null
+++ b/meta/recipes-connectivity/neard/neard/neard
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/neard
+PIDFILE=/var/run/neard.pid
+DESC="Linux NFC daemon"
+
+if [ -f /etc/default/neard ] ; then
+ . /etc/default/neard
+fi
+
+set -e
+
+do_start() {
+ $DAEMON
+}
+
+do_stop() {
+ start-stop-daemon --stop --name neard --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/meta/recipes-connectivity/neard/neard_0.9.bb b/meta/recipes-connectivity/neard/neard_0.9.bb
new file mode 100644
index 0000000000..61ea58cc14
--- /dev/null
+++ b/meta/recipes-connectivity/neard/neard_0.9.bb
@@ -0,0 +1,57 @@
+SUMMARY = "Linux NFC daemon"
+DESCRIPTION = "A daemon for the Linux Near Field Communication stack"
+HOMEPAGE = "http://01.org/linux-nfc"
+
+LICENSE = "GPLv2"
+
+DEPENDS = "dbus glib-2.0 libnl"
+
+inherit autotools pkgconfig update-rc.d
+
+INITSCRIPT_NAME = "neard"
+INITSCRIPT_PARAMS = "defaults 64"
+
+# This would copy neard start-stop shell and test scripts
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/neard ${D}${sysconfdir}/init.d/neard
+
+ install -d ${D}${libdir}/neard
+ install -m 0755 ${S}/test/* ${D}${libdir}/neard/
+ install -m 0755 ${S}/tools/nfctool/nfctool ${D}${libdir}/neard/
+}
+
+RDEPENDS_${PN} = "dbus python python-dbus python-pygobject"
+
+# Bluez & Wifi are not mandatory except for handover "
+RRECOMMENDS_${PN} = "\
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth', 'bluez4', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
+ "
+
+#Additional
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests = "${libdir}/neard/*-test"
+RDEPENDS_${PN}-tests = "python python-dbus python-pygobject"
+
+FILES_${PN}-dbg += "${bindir}/neard/*/.debug"
+
+##=============================
+# This is valid for 0.9+
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+ file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \
+ "
+S = "${WORKDIR}/git"
+SRCREV = "7abdb13d106d496e1115fab49e6448a249dfb3c8"
+PV = "0.9-git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.kernel.org/pub/scm/network/nfc/neard.git;protocol=git \
+ file://neard \
+ "
+
+EXTRA_OECONF += "--enable-tools \
+ "
+
+